White dot in the center of the screen (crosshair)

Just got my Spectrum, and it looks really nice and all, but I have what appears to be a dead pixel in the center of the screen.

I wanted to upload a video, but it seems this forum doesn’t allow it.

1 Like

Make sure you have crosshair setting turned off in the monitor settings

8 Likes

Hey @Litanong,
Great to see you have received your Spectrum! I don’t believe this is a dead pixel. It looks like you have the crosshair enabled. Either navigate through the OSD to turn off. Or right press on the Joystick for the crosshair shortcut to turn it off.

6 Likes

OMG That was it! Thanks so much guys!

9 Likes