Unknown devices

Hi everyone, I tried to find a solution looking in the forum, but nothing helped…

Since windows update, I had issue with driver, like most of you. It has been fixed with latest drivers installed. But I still have some unknown devices (2 multimedia controllers and 3 unknown devices) for which I cannot find any driver. I tried bios updates, driver reinstallation…

On another hand, thunderbolt devices aren’t recognized in the thunderbolt app, I think it might be linked with those unknown devices.

Does anyone has a hint for me?

image


dunno. however this is what mydevice manager looks like for your reference.
from experience, my fingerprint scanner got bricked by and update a long ltime ago and the surposed solution/troubleshooting doesn’t work for me. in your case of the thunderbold recognition, i’d reccomend reinstalling the thuderbolt drivers.

Give this a try:

1. In Device Manager, right-click an unknown device and select Properties

deviceid1

2. Go to the Details tab

deviceid2

3. From the ‘Property’ drop-down menu, choose ‘Hardware Ids’

deviceid3

4. In a perfect world, this should tell us useful things about the hardware’s ID

deviceid4

5. But you’re more likely to get vague hecadecimal codes for vendor and device IDs

deviceid5

6. Take the 4-digit hexadecimal code from vendor (‘VEN_XXXX’) and device (‘DEV_YYYY’), and enter them into your search engine of choice separated by a colon: ‘XXXX:YYYY’.

7. Apparently this device appears in products from Gigabyte, EVGA, MSI… but they all agree it has something to do with nVIDIA’s GTX 970 GPU. That’s the driver we need!

A lot of hardware IDs can be traced down this way, and there are sites dedicated to nothing but linking hardware IDs and their associated hardware, especially thanks to our friends in the Linux community who often have to work a little harder to find drivers than Windows users.

Be sure to enter the XXXX:YYYY values into the seach bar of your search engine’s site: entering it directly into Chrome’s address bar makes it think it’s an IPv6 address…

4 Likes

So many thanks!! It worked! It was Intel® CSI2 Host Controller, and Kionix KXCJ9 accelerometer!
I keep that hint for the future!

Let’s go to the thunderbolt issue now! :wink:

2 Likes