Ubuntu 18.04 LTS on V


#1

Hey there,

I am just wondering if somebody tried Ubuntu 18.04 LTS on the V. Does it run smooth or are there any problems? Do I have to install special drivers or do adjustments to the system? It would be great to have a tablet/laptop with full Ubuntu support. The new Surface Go would work as well, but there will be no Linux Support for sure.

Greetings,
mopac


#2

Hi, I haven’t tried to directly install ubuntu on the device, but I have utilised the Windows Subsystem for Linux to get both Ubuntu 16.04 and 18.04 running on Windows 10 without any issues, including graphic desktop through remote x client.

As you have noted the main issue would be the drivers, specially the touch and type-c drivers. It is one of the reasons I opted to stick with using the WSL rather than direct install.


#3

Hi bulhanb,

thank you very much for the link. Could you be so kind and try to boot ubuntu 18.04LTS via live usb stick? Maybe touch and type-c drivers work out-of-the-box. I really would like to have a tablet instead of my bulky laptop. How is your overall impression of the system?

Greetings,
mopac


#4

Hi Mopac,

I have created a live-usb of ubuntu 18.04 and booted the Eve with it. Quiet impressed that things worked straight up from the live session both touch, and Type-C Gigabit network ( I didn’t try the external monitors) worked. I have to say the screen picture was absolutely amazing. As it was the live-usb it went into portrait mode on the screen. The attached keyboard and trackpad worked and so did the wireless network.

So definitely there is every indication that the Eve V works with Ubuntu 18.04 LTS. I hope this helped.

Cheers, Bulhan


#5

Thanks, seems so! Now I have to decide whether I want to buy the V or the GPD Pocket 2 when released. But I think the V will be a better deal, and the screen is a lot bigger! Do you plan to install Ubuntu directly in the future? Again, thank you very much!

Greetings, mopac


#6

You are welcome, As for the V it is worth, but may be wait a little to see the organisation stabilise.

I have no plans to install ubuntu as I work mostly with windows development environments. For linux development, I have a separate linux server, as for a client windows WSL meets my requirements so far.

I wish you the best in finding a suitable 2-in-1 device.

Cheers, Bulhan


#7

i have some problems with booting live ubuntu 18.04 LTS from USB. like, how did you do it? bios settings, did you use dd, Rufus or Unetbootin for making live usb and similar would be a real help in figuring out what i have been doing wrong.


#8

The bootable usb I used was built on an ubuntu desktop using the Startup Disk Creator. No changes to bios were required. I followed the ubuntu tutorial on creating a usb bootable was useful. I haven’t tried one with Rufus.


#9

Hey,

I had time over the weekend and put together an ubuntu 18.10 live USB with Rufus, and it worked. I booted the Eve and both keyboard and Type-c doc worked. I was able to browse the internet through the type-c network.

The settings I used are:

I hope this helps.


#10

Depending on how well you know your way with Ubuntu and Linux, would you mind poking around a bit for the fingerprint reader? I don’t have a V yet but I’d love to do get it running on Linux once I have it. ^^


#11

Did thunderbolt work? And does ur fingerprint sensor work?


#12

Thunderbolt dock worked perfectly, both network and video. However the fingerprint scanner on the V did not show up when checking the usb devices. Executed “lsusb” command on the live usb and the Goodix fingerprint device did not shows up.

So I dug around the internet and found there is a bug reported in the Ubuntu kernel affecting 16.04 up that causes the Goodix fingerprint device (used on the V) not to show up. You can look up details of the bug report here Goodix GF3208 (fingerprint reader) not being recognised by kernel/system.


#13

Thanks for checking it out! Looks like the fingerprint ready will require more effort than anticipated. However my V will need to arrive first, before I can do any poking around.

Glad to see that TB3 works out of the box though. ^^


#14

The good news is, it is not a driver issue but more of a kernel issue so hopefully it will get resolved soon. As for the TB3, I am actually impressed it works out of the box.

I use a Mantiz Titan TB3 dock and I have also tested it with a Dell dock and 2 monitors which worked perfect. Both of them were able to also charge the battery. The daily dock I use is the Mantiz.


#15

I install Ubuntu 18.04 on the EVE V along side Windows 10 and it’s works but I haven’t figure out to not boot on widows but boot with grub so that I can choose Windows or Ubuntu 18.04. I didn’t see fingerprint sensors on Ubuntu and had issues with Ubuntu with the rotation.
Besides of all that is works pretty smoothly.


#16

Grub should have detected it. If not you can edit the config files by adding an entry with the windows boot loader or use the grub tool to do it.


#17

Yeah… my screen was rotated 90degrees. I fixed it by plugging it into a monitor then unpluging it. For 18.04 but in 18.10 i have had no problems with screen rotation


#18

I had the same problem. Seems it is Windows 10 problem, but you can easily fix it