Spectrum standby mode

Hey……if no signal is rec’d, does the monitor go in standby? How would you set up monitor indicator light to reflect when it is in standby? Thanks

1 Like

This is correct; the monitor will go into standby when no signal is detected. I personally have my LED set to the breathe setting when in standby mode.

3 Likes

Agreed on standby, and it works really well, too.

I changed my colors and the breathing for both active and standby.

Active:

Fast pulse
R 255
G 0
B 255

Makes it quite fuchsia with a fast breathing effect. I’d love to use red, in keeping with the Eve logo, but full red just doesn’t look right, lol.

For standby, I’ve used:
Slow pulse
R 255
G 67
B 0

For an amber color.

2 Likes

I’m having trouble with the Spectrum going to standby correctly when Windows turns the monitors off after 15 minutes of inactivity (but the PC is not in sleep mode). I have two Spectrums, and they go black, but their backlights are still on, and they appear to disconnect from and reconnect to the PC after a few seconds of just showing a black screen (I can hear the Windows device disconnected and connected chime play). When I move the mouse, they start showing the desktop again, but all my windows have moved like the monitors were disconnected. At no point, even after waiting for a while, do the monitors go into standby mode.

If I put the PC to sleep instead, the Spectrums go into standby mode and turn off. However, when I wake the PC it’s like they were disconnected because again Windows has reset my window positions and desktop backgrounds like a monitor was disconnected (ie. moving everything to the primary monitor).

This basically means that I can’t let Windows turn the monitors off, because they don’t actually turn off, and I can’t sleep the PC because the monitors mess up all my window positioning by disconnecting.

Does anyone have any ideas on what the problem might be? Is it a firmware bug? I didn’t have these issues with the previous two monitors that I was using before I switched to the Spectrums. If it helps, I am running Windows 10 20H2 and I have a Geforce 1070 on the latest drivers. The Spectrums are connected via DisplayPort 1.4, with brand new cables rated for the highest speed.

8 Likes

In testing my prototype, I found that it took some time for the screens to go into sleep mode after being told to do so by Windows.

First thing to note - this works a lot better now on newer firmware versions, and especially on Windows 11, but the main change for the prototype was moving from DP on my GTX 970 to HDMI. The monitor has become much more responsive, and I think it is a combination of both fw + HDMI. On DP, for whatever reason, so many things would not work, including HDR, and the standby took up to 2 minutes or mote to enable (I changed the LED settings to fuchsia for on and amber for standby, so it’s dead obvious).

@LoneWolf - I found that happening a lot more with my prototype on older fw and with DP, now it usually comes up in 3-4 seconds. However, I never actually power off the monitor, just let it go into standby and power itself off after some time, I’ve not tried actually powering it off. That may be the difference in behavior, in that the monitor would like a few seconds when being manually powered on before it’s ready, at which point a lot of modern computers are already waiting for you to log in to Windows.

2 Likes

@Ratfink I ran into the same issue today.

It only happens with the DisplayPort input.

I switched to the HDMI input and the monitor does go into Standby w/ a little delay like mentioned here.

My problem is my video card only has HDMI 2.0b. So I rather use my DP1.4 port to get 4K 144Hz output.

Im running a Zotac GeForce GTX 1080TI AMP Extreme on Windows 10.

EVE Firmware: 102R875

I upgraded out of the box, so I cannot say if the previous firmware had the same problem.

Update (8/6/21):

I have purchased a bi-directional DP 1.4 to USB-C video cable. It comes in this Saturday PST time.

I will let you know if this helps remedy the issue until hopefully a firmware fix comes out.


Update: (8/8/21)

So my monitor now goes into StandBy with the same DP cable. Not sure why it wasn’t working before and why it is now. But I never tried reconnecting the DP cable until today. Simply unplugging the and replugging the cable seems to have fixed it for me.

2 Likes

Thanks for reporting back. And glad it’s working for you now ;D

1 Like

I tried unplugging and replugging my DP cables, in the hope that this might work for me. Unfortunately not, standby still does not work properly. :cry:

1 Like

Question for you - have you tried using a different power profile in Windows? I wonder if a certain power profile might have a setting or a few settings set by the OEM / another company that might be interfering.

Try a couple of your built in profiles, and maybe even make a brand new one with all your own settings entirely to see if it makes a difference…

1 Like

I don’t think it should make a difference but this is everything I did before it started working:

  1. Unplug the DP cables.

  2. Connect both monitors with hdmi (rating not in important) and see if Windows puts them into standby properly.

  3. If it does work with hdmi, try plugging the DP cables back in after.

That’s basically it.

Another suggestion: check and make sure in your power & sleep setting in Windows that the “Screen/Turn off the display” option is set to a time. I would set it to 1min for testing.

2 Likes

Based upon that, I may need to revisit my DP cable as well. Once I switched to HDMI and it supported HDR, I never considered going back to DP.

Thanks for the steps. Let’s see if this actually pans out.

2 Likes

I had a fiddle with power profiles in Windows. No dice. :cry:

I also tried using a HDMI instead of DP. The monitor will go into standby when using HDMI, which is better, but it still drops the connection to the PC and disconnects the monitor, which means all my window positioning gets trashed.

Switching back to DP after HDMI doesn’t fix DP. DP still refuses to go into standby and also disconnects and causes my windows to move. :sob:

3 Likes

I did some digging and found that quite a few people have similar problems specifically with DP connections in Windows.

According to this thread: Windows 10 multiple display - windows are moved and resized on display - Microsoft Community

Its been a known issue for 6+ years but it obviously doesn’t affect everyone.
Microsoft says they will release a fix in a OCT 2021 update.

You can get the fix early by signing up for the Microsoft Insider Program: Windows Insider

I would suggest you try these FOUR things before attempting to update to a preview update version of Windows 10 that I mentioned above:

First: try a different brand of DP cables if possible. Don’t worry about ratings for now.

Second: Check for Windows updates and update if you have any available

Third: You describe your windows positions getting shifted when you force sleep mode. To wake up your PC only move the mouse or hit the spacebar and wait until both monitors fully boot up before you login or do anything. Windows usually only shows the login screen on the primary monitor, the other monitor will be black but will have its backlight on.

Fourth: Try disabling USB selective suspend. It’s supposed to conserve power by selectively turning off USB ports that aren’t being used but it can interfere with the sleep function.

  1. Open File Explorer.
  2. Paste this in the location bar Control Panel\Hardware and Sound\Power Options and tap Enter.
  3. Click Change plan settings next to the currently active plan.
  4. Click Change advanced settings.
  5. In the window that opens, expand USB settings.
  6. Set USB Selective Suspend to Disable.
    usb-selective-suspend-windows10
  7. Restart the system for good measure.
3 Likes

Hmmm.

Microsoft says they will release a fix in a OCT 2021 update.

You can get the fix early by signing up for the Microsoft Insider Program: Windows Insider

What really tickles me about this is:

Oct 2021 is the proposed release date of Windows 11.

And you can get an early copy of Windows 11 right now by signing up for the Insiders Preview program (assuming your hardware is compatible).

I know because that is how I’m running Win11 on my desktop right now lol.

As for your advice - I initially used 2 different DP cables, but only had success after moving to HDMI. Or so I thought. More on that below. Also, I’ve always turned off USB Selective Suspend for years, now, as a part of setting my my systems to use the Ultimate power plans. I also disable the ability of the OS to suspend devices like my NICs and USB connected devices and even my mechanical HDDs, for that little bit of performance and instant, on-demand readiness. But if you’re power conscious (as in on a device powered primarily on by battery, or else want do your part with energy conservation, then any of these measures will increase power usage of your device. So, please consider that when making your choice(s).

As for waking up the monitors from sleep - my 1080p monitor, which is designated as my secondary monitor, wakes up first, and the lock screen will show on it - but after a couple of seconds more the Spectrum wakes up and the lockscreen shifts back over to the Spectrum, making it my primary again.

Now, back to the DP → HDMI switch I mentioned above. The biggest thing to note in my case is that I made a switch from DP to HDMI - but I also installed the very first Windows 11 leak right around the same time (I have a pretty good idea of when I installed the leak, but am a bit hazy as to when I made the switch from DP to HDMI - within a week either way of installing the leak, for sure, though). All this time I’ve been thinking that it it was the switch of input type - but it may very well be that Windows 11 simply handles communication with the Spectrum better than 10 ever will. And the message you got from the Microsoft forums seems to concur.

This coming weekend, I am considering cleanly installing Windows 11 on my desktop. If I do, I can easily first restore my Windows 10 backup and see if the monitor starts misbehaving again or not. But your post, with the Oct 2021 thing and Insiders mention, really makes me think that it’s at least partially Win10’s fault.

While I appreciate the suggestions of things to try to fix the issue on my own, I’m highly sceptical that this is solely a Windows bug or a power configuration issue. I have DisplayPort connected monitors at work and do not experience these problems with monitor standby. I have friends that have DisplayPort connected monitors for their gaming PCs at home and they do not have these issues.

To be clear, my problem is not only with the PC going into sleep mode, it’s also with the PC just putting the monitors to sleep after 10 minutes of inactivity and remaining on itself. So USB-suspension power settings aren’t something I think applies to my particular issues (not to mention one of the monitors isn’t even connected to USB at all, and still has these issues).

I’m currently stuck in a Covid lockdown, so I can’t do this right now, but I intend on taking one of my Spectrums to a friend’s house and trying it on their PC to see whether I can conclusively exclude the issue being a Windows bug or configuration. I did try connecting one Spectrum monitor to my laptop, which has an HDMI plug, and I experienced the same issues with HDMI and monitor sleep there as I do on my PC (ie. monitor will go into standby mode, but will disconnect from the PC and lose window positioning). I’ve used this laptop before on monitors with HDMI and never had any of these sorts of issues.

I suspect there are still bugs in the firmware that need ironing out. :cry:

2 Likes

Finally, back from vacation I can confirm this behaviour. One monitor is waking up as expected and one does not. I have an open ticket with support and they wait for my feedback. I hope they can resolve it…

My pc running an rtx 3080 had issues finding a monitor signal. Disabling fast startup on windows solved the problem for me. Hope it works for you too :crossed_fingers:

1 Like

It seems that one of my Spectrums is not going into standby (LED is still on) but the other one is. After waking up the PC the one that is not sleeping is not showing anything from Windows but is still recognised as an active monitor by Windows.

When I switch the DP ports at my graphic card (EVGA GTX 2060) the other monitor is affected by this. So my guess is that some signal connection between PC and Spectrum dioes not work with that port or with that cable… Or the Nvidia graphic driver is not yet full aware of two of these Spectrums…

So I wait until I get my Eve DP cables and will see if it is only a cable problem…

1 Like

@Ratfink I’m having this same issue - have you found a solution?

Unfortunately no, there’s been some newer discussion about it here, but no solution yet. I’m hopeful Eve manage to fix it via a firmware update.

3 Likes