Spectrum | Firmware 105 Early Access

I seem to be able to reproduce the screen blanking (which is only recoverable by turning power off and on again) by rapidly switching between Github in Dark Mode and a website that is mostly white. Am I taking crazy pills? Why does that make the screen blank out?

1 Like

I updated to the preview 105 firmware last night and can confirm that I am still seeing this issue today.

I am using an AMD RX 5700XT Graphics Card to drive the display at 4k 120hz HDR with Freesync enabled
I am running Windows 11 pro version 21H2
Screen will randomly go black when playing a game that natively supports HDR but will not recover without turning the display off, waiting for Windows to realize only 1 display is connected, and then turning the display back on

2 Likes

Thank you. Have you tried also with the official Apple Thunderbolt 3 0.8m white cable? Do you think it’ll work?

1 Like

That would be a fair assumption.

I have a laptop from work (HP Probook 700 something) which only has Intel integrated graphics.
The chip in that machine can maximum do 4K 30hz via HDMI (I got a little scared there as it is not pleasant to work on) and 4K 60hz via USB-C.

So instead of assuming, you can probably find your CPU model name in the OS or from the laptop model and producer’s website and then check the integrated graphics specs on Intel’s website.

1 Like

Hello Eve team.

I’m experiencing a weird bug on my Model 3 monitor with the latest patch, where after I turn off and turn the monitor back on in the morning (without powering off the source), the cursor feels very stuttery and the ufotest is all over the place. The solution to this is to restart the monitor a couple of times until it feels right. How do I go on about reporting this properly?

System consists of:
Model 3, 105 update and has been reset a couple of times
Windows 11, latest update
nVidia 3070, connected via HDMI 2.1, latest update
A secondary qHD 144hz monitor from Samsung that doesn’t seem to be affected by this issue

1 Like

There’s definitely an issue here with Intel-based Macs. I’ve got a late-2019 15.6" MBP and it’s also limited to 60Hz output, despite being capable of more.

I’ve done a lot of searching to see what the cause of this might be, and there are people around the internet reporting similar issues with other monitors. Some of those have been fixed over time, but not all, which leads me to think that Apple are doing something screwy here. It seems that everything was working fine through to Mojave, and it’s from Catalina onwards that the problems started.

If you use a USB-C to DP cable, you should be able to get 144Hz no problem. But then you’re not using a single cable for charge + video.

1 Like

Hey, @Adam_Neshan

Yeah, the symptom you’re experiencing seems to be directly related to that particular setting, and it is being investigated now more thoroughly to see why this is happening. If you manually set the port prior to powering on the console, does it wake from sleep when the console is powered on?

No, you’re definitely not taking crazy pills - but a solid thank you for discovering this and bringing it to our attention. This is something that I do not recall being mentioned before, and it may give the fw dev team some insight as the the native cause of the blanking issue, at least in certain scenarios.

I’ll bring this to their attention.

After flashing to v105, did you try performing a Load Factory defaults on the Spectrum, than go back and set it up the way that you want again?

Also, what happens if you manually select the video input instead of using Automatically select, does it affect the issue?

Finally, Can you try disabling HDR, then on the Spectrum, disable VRR / Adaptive Sync (they show in the same place, VRR if you use HDMI and AS if you use DP, OSD → Performance Tab → second item on right).

After a bit you can re-enable it and then verify the monitor is recognized as FS2 in your driver, and then finally enable HDR again.

See if this stops the blanking.

This is actually a known issue with nVidia drivers for the last several drivers. nVidia has even released a new driver today, 511.23: NVIDIA DRIVERS GeForce Game Ready Driver WHQL

Release Notes: BkNVR510_Win10.book (nvidia.com)

From that PDF:

Fixed Issues in this Release
Flicker/disappearing text occurs when 12-bit color is used. [3358884]
Random flickering occurs across the top of the screen when using desktop applications. [3427298]
In multi-monitor configurations, the screen may display random black screen flicker. [3405228]
[Detroit Become Human]: Random stuttering/freezing occurs in the game. [3389250]
[HDR][G-Sync]: Mouse pointer gets stuck after turning on HDR from the Windows Control Panel or after toggling G-Sync from the NVIDIA control panel. [200762998]
To work around, click the mouse (right or left button). The mouse cursor will be sluggish for a few
seconds before returning to normal operation.

I highly recommend that you (and everyone in here using nVidia GPUs, even if not 30 series) grab this and test it out. As nVidia is now claiming to fix multiple issues that the fw dev team is attributing to the driver, this will help us narrow down issues to fw versus driver.

Please Note: When installing this driver, to help out with the reporting process, please install this driver using the clean install method. Utilities like DDU do not need to be used, but can be used at your own discretion.

To clean install, run the driver installer, let it extract, agree to the license, then when the asked to select installation type Select Custom (Advanced). Click Next, then make sure to check the box near the bottom that says Perform a clean installation.

2 Likes

I installed 105 and had a lot of color issues that others were describing. Anything over 60hz went down to 6 bit color with no HDR. I tried rolling back to 104 and now my monitor is bricked. It won’t turn on, nor will the flashing tool recognize that it’s plugged in.

Edit: After enough power cycles it eventually worked. I can confirm that 144hz is working again with full 10 bit color, so there seems to be an issue with 105.

1 Like

I have done the new Nvidia driver clean install and have no issues with vrr anymore. I am on firmware 105.

1 Like

Installed the new firmware a few days ago. Some notes about my exprience so far:

  • Installing 105 reset settings to factory defaults and deleted all saved presets. Not a huge deal for me personally but I can see this being a nuisance to some users. (Assuming I’m not the only one this happened to.)
  • Blanking issue seems to be fixed, yay! Need to spend some more time testing to be 100% sure, but it’s looking good so far.
  • B&W HDR fixed
  • Input auto select prevents the display from going into sleep mode for me as well. This happened occasionally on 104 too, but now it’s a constant thing.
  • Still experiencing vertical image shifting when using 144Hz. There was no mention of fixing this on the patch notes so not that surprising. Just thought I’d mention it all the same.
  • Waking up from sleep mode is slightly faster, which is nice.

I’m using Win 11+RTX 3080(drivers 511.23) and HDMI cable provided with the display.

2 Likes

Experiencing blanking issue constantly on one of my Spectrum monitors running over USB-C to my Macbook M1. It really is quite infuriating, having to disconnect the monitor, wait 5 seconds and connecting it again only to have it blank again a couple of minutes later.

Turning off adaptive sync helps a bit, I think.

1 Like

Did you perform the rollback as described in the original post?

Hey, @kevmodrome

You say “on one of my Spectrum monitors” - but not on any others?

How many do you have? How many do you use with the M1 MBP at any given time? What happens if you reverse the connections?

I observed some odd behavior with the Netflix app, and MS Edge browser Netflix using HDR with subtitles.

It seems that the Windows app doesn’t recognize HDR content being available, but the MS Edge browser does.

More importantly, both versions showed issues with subtitles. They caused frames to blank out completely as they displayed, and the monitor displayed them as being part of the HDR content as well. This resulted in the monitor getting overly bright whenever a sub-title displayed.

The workaround was to disable HDR in windows to switch to DCI-P3 while watching Netflix.

1 Like

It actually started happening on both of the Spectrum monitors. It does not happen on any other monitors I connect. Generally happens with and without thunderbolt dock on all ports.

It specifically only happens when connected via USB-C to the Macbook though. Not when I connect them via USB-C to my Workstation.

1 Like

This has been a problem with Netflix and HDR content for years. The subtitles default to being bright white, which means they’re super-bright when you’ve got the right (wrong?) screen.

As a workaround for this, you can go into your Netflix settings and there’s an option somewhere to change the subtitle colour. I’m currently using a very very light grey and it makes a massive difference.

4 Likes

for those having hdr color issue. Windows has an update for it. double check the link if the known issue is the same as yours.
January 17, 2022—KB5010795 (OS Build 22000.438) Out-of-band (microsoft.com)

3 Likes