Screen tearing with Freesync on and above 140 fps

When I have Freesync and only that on there is consistently screen tearing along the roughly the border of the bottom 10% of the screen. I’ve had to limit framerate to roughly 140 to reduce the severity of the screen tearing.

What’s your input source? Have you tested other cables? I hunger for moar data!

Hey @Shadowbeing

Using only FreeSync means you are using DisplayPort. Can you verify for me that you are using certified DP 1.4 cables?

If not are you using a verified Type-C 3.1 gen 1 or higher / Thunderbolt 3/4 cable?

Regards,
Bobby

Hey, sorry for the late response. I am currently using these cables. I just switched to the beta firmware to test the black screen issue fix and have noticed that the tear moves up to roughly the center. For consistency I can switch back to the current release. There any other info you need?

Looks like they do support DP 1.4 but that specific length isn’t VESA certified. Is that the certification you were looking for? @Aethel

Yes, the fact it is not VESA certified could be the reason you are experiencing screen tearing. Are you able to get a hold on a VESA certified cable? That could be the fix we are looking for here.

I would first check that FreeSync is actually working. Start by going into the Spectrum’s menu and into Performance, and check that Adaptive-Sync is set to On. Also go into the Gaming section and enable the frame rate counter. Does the counter change as you’re playing, or does it remain on a single value the entire time?

If the counter doesn’t change, or it only changes by +/- 1, it means one of two things:

  1. FreeSync isn’t actually working and you’re using a fixed frame rate, which can result in tearing.
  2. Your graphics card is powerful enough to be constantly pumping out >= 144Hz. Try going to a higher resolution or increasing the graphics settings, at least temporarily.

If FreeSync is working as expected, you can then start looking at other causes.

The cable is a potential issue, but not due to lack of certification. The length is far more of a concern (13ft / 4.0m), as longer cables are more susceptible to electrical interference. Is your screen really that far away from the computer that you need a cable this long? If there’s any chance for you to use a shorter cable, give that a go.

If you truly do need a long cable, look for one that uses fiber optics ($$$) or something that’s rated for DisplayPort 2.0. I found this cable on Amazon that would probably suit your needs. It’s supposedly rated for 80Gbps, so should be more than capable of handling the 32Gbps that DP1.4 uses.

@Aethel Just put an order in for the 10ft VESA certified variant of the cable I already have. I’ll update this post with results once I get it.

@NZgeek FPS does change appropriately. Upon looking into the certification it does seem like length is a reason why the standard only supports up to 3m it seems.

Some more things I’ve noticed is that it appears like it doesn’t happen on rocket league but it becomes very obvious in deep rock galactic and decently noticeable in destiny 2. One observation about testing in deep rock galactic was that when I would set the in game cap to something like 140 fps, the steam fps counter would reflect that but the monitor fps counter was staying at 144.

I have acquired the new 10ft certified cable and it does seem to have helped.

In deep rock galactic I can barely see screen tearing at 144 but if I drop the cap to 143 I can’t notice it anymore. Destiny 2 was looking good at 144 and rocket league looked fine at 144/143. I think I can mark this issue off for now.

Seems like the monitor is fine and it’s an issue of cable and game. Curious if it’s due to something like the speed at which the graphics card and monitor can communicate. Gonna mess around with it for a while longer and if no more issues arise that I can pin as the monitor I’ll close this thread.

4 Likes