Screen blanking after firmware 104 while gaming?

With 102R875 there is also a problem when you enable GSYNC compatibility. It is like a micro stuttering when moving in game. This directly disappear when you disable GSYNC. Without it is buttery smooth…
Is this also investigated?

1 Like

It would probably help if you provided precise information about your setup.

System build, at least to the extent of CPU architecture and motherboard.
Multiple monitors or single?
Cables? Ugh… the cable. Please provide specific info on the cable type and manufacturer.

I guess what I’m saying is more info is 'mo betta for their actual QA team. I mean no disrespect in any way to you.

1 Like

You should always turn Vertical Sync off in a game if you are using G-Sync or Freesync.

2 Likes

I was able to eliminate my issues by disabling g-sync. Switching to BFI gives me most of the benefit of g-sync in the games I play (DRG, SoT) since generally they can run fast enough not to stutter/tear. Just another data point for the team. Side note: I can’t run HDR + 4K + Gsync anyway (not enough bandwidth from a 1080 on display port).

No, or at least, I doubt it. This thing isn’t even remotely as hot as my 3007WFP was. That thing was so hot you could feel it from 25cm from the screen.

Thanks for posting this, I thought I was going insane. I’d try to run at 1440p and it’d still say 4k in the OSD.

Maybe it is a Nvidia problem: https://www.nvidia.com/en-us/geforce/forums/game-ready-drivers/13/476666/geforce-49709-grd-feedback-thread-released-12121/
under open Issues:

  • In multi-monitor configurations, the screen may display random black screen flicker. [3405228]

Nvidia released a fix for vertical sync while using gsync.

Interesting.

I may switch back over to the Game Ready driver to test. My main concern isn’t the gaming but the rando window placement when coming out of sleep. But it could be somewhat related since I did have GSYNC enabled across the board.

Random window placement when coming out of sleep is just a standard Windows thing with multiple monitors - when a monitor goes to sleep it typically ‘goes away’, so Windows will rearrange your desktop to fit on the remaining monitors.

If you have a single monitor and your main one goes away, Windows switches your desktop to a ‘simulated’ monitor with a fixed size (configured in the registry), and that fixed size may be significantly smaller than the real monitor and cause your windows to be jiggled around a bit. See How can I stop windows re-positioning after waking from sleep? - Super User

I mean… I understand that it used to be an issue but it seems that most modern monitors coupled with the recent updates to Windows 10 (those which are now baked into Win11 so I’ve heard) handle existing application window placement without issue. And I’ve seen this article. It’s a hot mess. However I must have overlooked that section so I will review the virtualization aspect.

It’s noteworthy to mention that it is ONLY when I introduced the Spectrum into the workflow did this start occurring again. And subsequently, it’s ONLY windows that were on the Spectrum which are being moved. LOL. So if that’s not enough to state the issue lies with whatever this monitor does on sleep/wake I don’t know what you’re looking for.

I have a friend with an LG 27GN950 (same panel our Eve 003 uses) that has a similar sleep/window issue. Whenever it goes to power save it’s as though Windows forget it exists and resets all window positions. I’ve experienced this same issue on my Spectrum, but very randomly.

In a firmware update (last few days) they apparently fixed the issue and it no longer causes everything to reset when the LG sleeps.

We have different internal hardware from the LG but perhaps this sleep/window issue is from a common piece of hardware?

I wouldn’t correlate the experience 1:1 with a panel in an LG product only because the firmware is different; as you’ve already stated.

Just because they perform a certain way doesn’t mean that the Spectrum is going to be the same…