Quick update about drivers & firmware

If it was à big brand you would have a UEFI tool to access to your bios settings.
Here you d
Need to restart on it to have the information. Ir’s explained in the support version to how access it.

The beta BIOS is dated 15/3/2018 or 3/15/2018 depending on your computer config. Looks like you have the old one.

Hum, interesting.
Didn’t work for me though.

i don’t know if it’s the right place to ask this, but does any one of you know when does eve will make a bios update to change the 2 lane PCI-e to a 4-lane, i remember about 8 months ago, @iKirin (i know you do not work anymore for eve, but maybe you know something) said that eve just needed to work with intel to change some option in bios to make that work, i’d really like that for my egpu, so i could plug a couple of thing on it without losing bandwidth! Thank you.

2 Likes

For people having trouble getting thunderbolt drivers such as from reinstalling a fresh windows. you can use the same drivers as the intel NUC. It’ll work just fine.

1 Like

Windows Defender doesn’t like sensors :frowning:


This is false flag, is’nt it?

Definitely false. Gosh this is why I hate antivirus… Especially when I use Windows, Office, or other activators, for educational purposes only of course.

2 Likes

There is a way to update Thunderbolt firmware without connecting a device.
First, go to this page and download any firmware update for the Intel® NUC Kit.

Extract these four files over your Eve V Thunderbolt update files

  • FwUpdateTool.exe
  • FwUpdateAPI.dll
  • ForcePower.reg
  • wmibios.dll

Then, you need the Thunderbolt software. Any Thunderbolt software package for any device should work. For example, this link. Then install.

Double-click the new FwUpdateTool.exe and it will ask if you want to enable updating without any Thunderbolt device attached. Accept and restart your Eve V.

Run FwUpdateTool.exe again, and if needed, close the Thunderbolt software tray icon if you encounter any error.

If your Eve V needs update, feel free to update.

If you want to reverse the ability to update without any Thunderbolt device attached, save this batch script as .bat or .cmd file and run the batch file as administrator.

REG DELETE HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WmiAcpi\MofImagePath
del C:\Intel\Thunderbolt\ForcePower\wmibios.dll
echo eve.community reserver's UnForcePower - Please restart your Eve V for changes to take effect.
echo This reverses the ability for updating the Thunderbolt firmware without connecting a Thunderbolt device.
echo https://eve.community/t/quick-update-about-drivers-firmware/16941/55?u=reserver
pause
6 Likes

I had some intermittent behavior on my replacement V keyboard, so I installed the latest firmware according to the instructions.

Afterwards, keyboard and touchpad no longer work.

Tried rebooting…still not working.

Tried reinstalling the firmware update…no longer recognized by the software.

Disconnecting the keyboard and plugging back in gives me an error message:

USB device not recognized.

Any ideas on how to reset keyboard or fix this?

Thank you!

Doing a full Windows 10 re-install did not fix my issues with my keyboard. I am back to using my V as a tablet again.

Nobody else has any issues with the keyboard firmware upgrade?

No, not with the firmware update.

Support?

1 Like

You could try booting a Linux live stick to see whether the issue is Windows or the keyboard itself.

2 Likes

Hi all
I just got my Eve V from a friend. After setting it up i saw that windows does not recognize some of the devices in the product. This is evident when looking at the device manager.

I think one of the devices must be the fingerprint reader. Since it is not shown anywhere else. Can this somehow be fixed by installing drivers? Or is there any other solution?

Yes driver would surely fix.

If you double click on each item, you could check the hardware ID, the fingerprint sensor is GXFP3200 or something like that

I have a similar problem, I reinstalled WIN 10 1809 on a clean harddrive, now a number of unknown devices pop up in the device manager window. I have downloaded and installed all the drivers from eve-tech.com, alas to no avail…
(The fingerprint sensor had stopped working before, so that’s not a new issue. It is still annoying, though…)

1 Like

I tried booting from a Ubuntu live image and still no luck.

The firmware upgrade process went just as described in the readme, but it definitively ‘bricked’ my keyboard.

I hope that @Team takes the firmware for the keyboard down as I am now without a keyboard again. This was my replacement that I waited a year for.

Still love my V!

We tested keyboard firmware so it shouldnt be the root cause. I’ll ask software guys too but for this issue better contact support.

4 Likes

Just want to bring this issue up again, I was wondering if there would be any driver updates fix for pen jitter issues?

There’s an article talking about Surface pro models receiving updates and I’ve checked [reddit] where people have claimed their pen jitter have been fixed/improved after updating! I do hope the Eve V would get the same updates as them because I’ve been waiting for this issue to be solve for a long time!

[Microsoft’s latest Surface Pro firmware update fixes Surface Pen accuracy issues]

Anybody having an issue getting their V to sleep? When I close the keyboard, it doesn’t put it to sleep. Thanks in advance!

It goes to sleep but wakes up from it due to some windows related issues - I’ve seen it quote a bunch on Windows already :confused:

1 Like