Problem: pink tint on screen using 8K 2.1 HDMI with macbook pro

I’ve bought a new HDMI 2.1 8K 48Gbps cable that would support the high throughput and when I connected that to the monitor - it just gives be a really pink tint on anything it shows. The cable is completely new, even tho I’ll try to buy another cable just for the sake of it. Attaching pictures of my macbook pro monitor for comparing the color tint between the Eve Spectrum.

The macbook pro is 2017 15" without True Tone with macOS Catalina 10.15.7

I tried connecting different monitors to the laptop, and that works through my setup. Spectrum gives weird pink tint. Currently firmware is as it came - 102, there’s no easy way to install 104, but I doubt that fixes the problem where it’s just a regular connection.

EDIT: On top of that I only get 4k 30Hz support on the monitor settings. Tried 2 cables. One of them acted normally for 5 minutes, and then turned pink straight on. Any support would be appreciated - thanks!

EDIT2: Forgot to mention that I am using a USB-C hub that helps me connect any advices through USB-C (in this case I’m using HDMI through this product). The product is here Type-C Multi-Port Adapter | USB-C Dongle - Satechi

1 Like

@Zigmas_Slusnys Thanks for the report. Let me get with our team members who have MBPs to test with to see if this has occurred before, with fw ver 102 specifically.

1 Like

Thank you in advance. Probably additional thing I forgot to mention, which I’ll update in the main post is that I am using SATECHI USB-C hub and I connect the HDMI cable through that into my laptop.

Here’s the URL to the product I use for that: Type-C Multi-Port Adapter | USB-C Dongle - Satechi

1 Like

Does the issue occur if you eliminate the hub from the chain?

I only tried HDMI cable which I require the hub to have a connection. Could this be some weird case where monitor reads the signal wrong that’s being transmitted? Not sure actually what the problem is. I tried the HDMI on another computer without the hub, and it was showing results without the tint. This shouldn’t be the Apple situation tho where one should need different hubs and dongles for an external device such as a monitor to work, in my opinion. Also I want to repeat myself that other monitors work through the same hub and HDMI properly.

1 Like

That was my thought as well. Unfortunately, I don’t have experience with MBPs myself, so I cannot say one way or another what the case may be - whether it is a setting in the Mac that needs to be changed, or else if it is the USB hub, or something else, such as a firmware issue.

Let me try to find more information and get back with you - and hopefully others in the community might also have answers.

I reproduced the same with a 2017 MBP 13". HDMI via USB-C Adapter (Hyperdock)
It was fine before upgrading to Monterey.


I’m currently on macOS Catalina 10.15.7

1 Like

Another user, @Bexin, reports the same issue with a test unit he used with that exact OS as well.

I do not know if this is firmware related or not, but I’m hoping that Bexin will come in here and be able to provide some more clues as to what was / is the cause, and if there is any resolution to it.

Still researching, though!

I had the same issue with my Hyperdrive USB-C Dongle but when I switched to Apples own dongle that supports TB3 the pink tint went away. However I still only got 30hz

1 Like

@mauimauer - that is interesting to note. So, my understanding is that you used that same dock with 0 issues on your MBP until you upgraded to Monterrey? Can you specify which dock, and also what, if anything, you were able to do to get it to stop doing this, or, conversely, if it is still occurring?

With us now having 3 data points instead of a single one, including Bexin’s, it will be a lot easier to start troubleshooting it.

4 data points! Thank you for this! It’s interesting to note that yours went away when moving to the official Apple dock, too. I suspected something like this might be the issue.

As for the 30 Hz issue, we’ve brought this up with our firmware team. When we know more, we’ll be sure to relay the information.