No signal with the Spectrum on GPU. Works on iGPU and PS5

Hi!

I received my Spectrum 4K yesterday and it worked fine in Pop!_OS 21.10 for several hours using desktop, playing games and watching videos, until I unplugged it and plugged it back in at one point. Then my graphics card completely stopped responding and I couldn’t get a signal using even my secondary monitor (even in BIOS), though the fans are still running. It works perfectly fine with my PS5 using the HDMI cable that was included with the console.

My initial setup:

  • ROG STRIX Z490-F GAMING
  • 2 x GTX 970 running in SLI
  • BenQ GL2450HM 1080p monitor connected through HDMI
  • Spectrum connected through DP using Eve DPK8 cable I ordered with the monitor itself
  • Pop!_OS 21.10

In between almost every step as described below, I completely shut down the computer, remove power cable and wait at least 30 seconds.
At first I removed one graphics card, then switched to the other without result. I couldn’t even use my old monitor to get a signal. I reset CMOS and managed to get a signal to the old monitor but when I disconnected it and connected the Spectrum again (DP) I lost signal again (including plugging the old monitor back in again).
Still using one graphics card and another CMOS reset I booted back into Windows using the old monitor. At desktop, I connected the Spectrum in addition to the old one and I got a signal from both but explorer bugged out and I could only see the taskbar and wallpaper. When I pressed the Windows key, the running apps changed their icons as if focus was shifted but nothing happened on the display (i.e. it’s not completely unresponsive).
I shut down and removed the graphics card and connected to the iGPU but it didn’t work until I reset CMOS once more. Booted into Pop!_OS fine again. I then booted into Windows 10 to try to upgrade the monitor firmware following the manual and these instructions: Project: Spectrum | How To Update The Firmware but I can’t get past “Device Disconnect…”. I tried three different cables: One Eve USB-C I ordered with the monitor, one I received with the charger for my iPad Pro and one that is USB-C in one end and and B in the other that I received with the PS5 to charge the controller. I tried connecting my iPad pro both to the motherboards USB-C port and the Spectrum’s to confirm that the ports work (the monitor USB-C port charges, but when I tried connecting my Bluetooth dongle to one of the USB-B ports, it didn’t work).
I proceeded with uninstalling the display drivers using DDU but it makes no difference.
Further, I’ve tried connecting the PS5 HDMI 2.1 cable to the iGPU as well as the HDMI cable from my old monitor (in both 2.1 mode and 2.0 mode through the monitor settings) but only DP seems to work.

I can’t think of anything else to try right now and would happily receive any assistance you can provide. Loving the monitor so far, I just hope I can get past these annoying errors.

So an update. I managed to get hold of a different graphics card and it works (funnily enough, I tried with my old GTX 970 in another computer and the monitor worked fine). However, now I run into a problem where the screen will black out every few seconds when running at 4K 144 Hz. Tried 120 Hz and it’s even worse (blacked out for most of the time with small glimpses of function). When I set it at 60 Hz it seems to work fine.

I also can’t seem to get any life out of my USB ports. It’s powered as it’s charging my iPad when I connect it but neither my wireless mouse dongle nor my webcam are recognised when I connect them to the USB-B port. I’m using my Displayport 1.4 cable right now with a graphics card that supports it (AMD Radeon 5700). It doesn’t matter if I change any settings for the USB hub in the OSD.

1 Like

Hi @ChrisofAllTrades,

I’m glad you’ve got your Spectrum working again.

In regards, to the Spectrum blacking out every couple of seconds is a known issue and we are looking to resolve this in the upcoming firmware updates.

I remember someone running into a similar issue to you. Please can you try the below.

  1. Device Manager > Human Interface Device > (Locate USB Dongle for Mouse and Select) > Power Management > Uncheck “Allow the computer to turn off this device to save power”
  2. Control Panel > Hardware & Sound > Power Options > Change Plan Settings > Advanced Settings > USB Settings > Disable

Hi! Sorry for taking so long to reply. I tried the two steps you suggested but it doesn’t make a difference. It still doesn’t register if I plug in something either through the USB-B port or the USB-C port (of course changing the USB Hub Source in between). I confirmed that the USB-C cable works when connecting my iPad to my motherboard.

Edits: Also maybe relevant is that I’m able to use the monitor’s 3.5 mm audio jack without issue.
I’m currently running Windows 11 and the other 1080p monitor isn’t connected anymore.

I now use a AMD Radeon RX 6600 XT and it works almost perfectly with no blanking except for once or twice per hour while playing games (not sure if resolution makes difference, I switch between 1440p and 4K but I haven’t noticed a pattern).

1 Like

Hey Chris! Good to see it works fine with the GTX 970 - 'cause that is what I’ve been running with my Spectrum for 6 months now.

With regards to the USB issue - the bottom ports (Type-C and Type B) are upstream ports - used for the hub source. The side ports are the downstream ports - aka where you want to connect your peripherals to to use with the device in question.

Now, there is a bug in which the automatically select is not working correctly, and it is fixed in the next firmware version. I’ve already tested it, and automatically select USB Hub source works as it was originally intended. However, it does not seem the proposed enhancement, where you can pick any port to match with any video signal, is working correctly.

For more on this please refer to this topic: Feature request: usb hub selection per input

So, just to be sure: Regarding the USB ports - you’re using the ones on the bottom to connect to your devices and the ones on the side to connect your peripherals to share between devices, correct?

2 Likes

I feel kind of silly right now, I didn’t even realise there were USB ports on the bottom as well! :sweat_smile: It immediately connected in the firmware update software and I will install the latest firmware to see if it helps with the black screen issue.

By the way, I’m not surprised it didn’t work properly with my GTX 970 considering it’s a very unusual combination to have a seven year old graphics card with a one year old motherboard.

Thank you so much for your help (and MarvyMarvz too)!

3 Likes

Worry not, m8 - you are by far NOT the only one to miss them…