Nintendo Switch not working with Spectrum

I haven’t seen similar post here yet, so I am hoping to get some help.

My Spectrum arrived today, I connected it right away to my windows laptop so I could use it for work, straight from the box. No problems at all, USB-C → DP cable worked fine.

After work I decided to try other devices I have at home and the only not working so far is my Nintendo Switch (first model, HAC-001) :frowning:

List of the things I checked before creating this post:

  1. Switch works with the previous monitor I used (even though it didn’t have HDMI, I used DVI - HDMI adapter)
  2. Switch works with the other two HDMI displays I own (Phillips TV and Dell monitor)
  3. Spectrum HDMI ports 1/2 behaviour is the same, 2.0 compatibility turned on doesn’t make a difference
  4. I used the same cable - one provided with Switch - across all devices - Spectrum is the only where it doesn’t work
  5. I also used the same cable to connect other devices to Spectrum - PS4 Pro and my Windows laptop - and they worked!

It’s not like I didn’t get anything displayed on Spectrum from Switch, one time I saw the wake up menu from Switch, but once I tried to unlock it - signal was gone. After that it seems like it is in some loop, looking for signal and not being to display anything.

Any help will be appreciated, thank you!

EDIT: forgot to mention, I checked 102 and 104 firmwares

1 Like

Thanks for the report. Let me do some research to see if other Spectrum owners have mentioned the Switch and ability (or lack thereof) to get a signal.

1 Like