My Spectrum Experience and Findings

Sooo:

After I had some time to mount the Spectrum and rebuild most of my Setup, I’m ready to share some of my experiences with the Spectrum.

Firstly, my Setup and my use cases:
I had 3 x 4k@60Hz Monitors before I got the Spectrum, currently running the Spectrum and 2x LG UL650-W.
I’m a Developer, so this is my primary use case.
My second use case would be gaming, mostly Shooter (Apex, COD, BF).
Specs of my Main PC: 5600x, 32GB RAM, AMD 6800xt, Windows 11

Now to the Spectrum itself:
Long story short:
That thing rocks, playing at 4k@144Hz is a new world if you had to live with 4k@60 before.
You can literally see where the Dummy is going on Kovaaks Close fast strafes and generally the Voltaic Playlists :smiley:

The Panel:
The Panel looks really good, I haven’t thought that you can see a difference between my 650-Ws and the spectrum but boy was I wrong.
I did some calibration with my Datacolor Spyder 5 Elite, after that the Picture was even better.
I use the DCI-P3 Color-Space with a Brightness of 35, this is around 180cd/m2 and matches my other Monitors and my general preference.
What really stands out: The Red colors are REALLY Red and I mean “I’ll burn your eyes out”-Red (only in DCI-P3 Mode), this is something I had to get used to. It really is a shame that we can’t save Color-Profiles on the Monitor itself.

The Design:
The Spectrum looks damn good, not a “Gamer in your Face with a ton of RGB”-Design.
I have wall mounted all my monitors, so I can’t say anything about the stand, but the Monitor itself is gorgeous.
I needed some time to get used to the Joystick, but after that, everything worked fine.
I think we really need some more customizing options for the Joystick (the left, right, up, down Options.

My journey:
On the first day I updated to the Forum version “102Rxxx” and started to play around with some cables. I’ve tested 6 “HDMI 2.1” cables, there were only 2 which worked for me.
So, you really must look at the cable and get one which is a verified HDMI2.1 (ultra-high Speed) Cable. There is a QR-Code with every certified HDMI 2.1 Cable which you can check with the HDMI Mobile app.
The Display-Port 1.4 Cable worked first try, so no problem there. It is currently connected to my second PC which runs Unraid with some VMs and Hardware-Passthrough.
I haven’t had the chance to test the USB-C Port, but I’m in the process of getting a Docking-Station for my Laptop, after that, I’ll try this.
After that I updated to 104 and everything is still fine. I haven’t had a single new Bug between 102Rxxx and 104.

Currently my Office-Mouse and my Keyboard + Numpad are attached to the Spectrum and connected via USB-B to my PC. This worked fine AFTER the 102 Update, it was unusable before the update.

BUGs:
I had some bugs, nothing which makes the Spectrum unusable, but I want to share them:

  • The USB-Hub doesn’t work at the Bootloader Menu, so I can’t select which Windows to boot – That’s quite annoying NGL.

  • If the Monitor isn’t powered on before the PC starts, the Monitor stays Black and I can’t see the Windows Login screen (only happens in a Multi-Monitor Setup)

  • I can’t select 4k@144Hz with 10Bit on AMD 6800XT, but this works with Nvidia (tested with a NVidia 3060ti FE), would be nice if this can be fixed via Firmware - Maybe an EVE + AMD Problem? 4k@120Hz and below + 10Bit works fine.

  • Random “Split-Screen”, I’ve added a picture blow, this only happened one time.


A picture of my Setup with the beauty in the middle:

And some calibration Charts:
DCI-P3:

SRGB:

A Picture of the “Split-Screen”:

Testing Testing :smiley: :


If you’ve got some questions I’ll try to tests/answer them :slight_smile:

2 Likes

Just to add. I’m running a 6900xt with a DP 1.4 cable and it immediately went to 10bit, 144hz. So odd it won’t let you, maybe a cable + amd issue? Idk

No. I reported this month’s ago on as part of my testing prototype Spectrum. Daft thing is 8 bit with dithering is what all GPUs should show, seeing as that is what the panel has as its specs.

1 Like

This is shown if I turn on hdr, no hdr just says „8 bit“

This worked with my 6800XT too, but I have to use DP. If DP is connect it says 144 10bit.
With HDMI it just shows 8 bit.

1 Like

Sure you have a 2.1 certified cable?

Can you show a screenshot please?

Yeah though it won’t know how to distinguish it. All the GPU knows is it’s sending a 10 bit signal.

How come you’re using HDMI over display port anyway?

Yes, but Windows knows it’s an 8 bit panel with dithering.

I tested 4 dif hdmi certified cables with my 6900xt, none showed 144hz@10bit. only 144hz@8bit or 120hz@10bit
VIA DP all is fine - 144@10bit.

Sure, will add some screenshots tomorrow

Because if I can use uncompressed 4k@144Hz via HDMI2.1, why should I use DisplayPort? :grin:
A mayor argument of buying this monitor was HDMI2.1 so I’m using it ! :rofl:

1 Like

Sorry for the delay, had to redo my cable management to get to the Displayport Cable.

HDMI 2.1 120Hz:

HDM 2.1 144Hz:

DP 1.4 144Hz:

HDMI 2.1 Cable works with 4k@144Hz@10Bit on a 3060ti,

What really got my attention:
The USB-Hub Firmware must be fixed, I had to restart my PC 3 Times while changing resolutions, because it froze up my whole PC.
Disconnecting the USB-B cable while changing the resolution worked… that was really annoying.

Also: The Monitor takes waaay to long, to get the new signal status.
The 10 second timer for the new resolution was nearly always faster than the Monitor.

I mean for PC I don’t know what benefit there would be to using HDMI 2.1 over display port 1.4

I thought the whole reason behind HDMI 2.1 on this monitor was for the game consoles, and not PC gaming as there is no advantage over displayport at 144hz 4k. I guess HDMI 2.1 technically has more bandwidth? But it doesn’t seem to matter at the resolution/framer ates. I get why that would be annoying if that’s the case, but idk, don’t see why it would matter to need HDMI 2.1 on PC for this monitor.

That’s fair enough but there isn’t a middle signal though which is specifically dithered over 8 bit right? It takes a 10bit signal at the end of the day and then the display dithers it to be able to display a higher amount of colours that the signal has.

Yup, that’s correct. The only difference is: HDMI 2.1 doesn’t need compression, DP 1.4 does.

My 6800xt has 2xDP, 1xHDMI2.1 and 1xUSB-C, so it made the most sense to connect the monitors the way they are connected now.
You could connect it the other way around, sure.
But it should run 144@10bit nonetheless, so I pretty much would like this to be fixed :grinning_face_with_smiling_eyes:

Oh yeah I’m not saying it shouldn’t be fixed, just saying, I normally just go with displayport. I hadn’t done much research into HDMI and didn’t know it was uncompressed while displayport is compressed at 144hz.

Not that it matters I had random blackouts of my display recently at 144hz, I tried 120hz and it stopped doing it. Everything be buggy.

1 Like

Not at my PC at the moment, but there is. With my 6900xt at 144hz Windows says It’s 8 bit with dithering. At 120hz it says 10bit.

These are with HDMI 2.1.

Update:
I’ve also got the random screen blanking with the HDMI2.1 port.
Currently I only got this happens in Warzone.
Happens maybe 1 time every 20 minutes.