Multiple Monitor Configurations Not Saving


#21

See here:

I guess every time you plug it in, it registers in a different position - i.e. Monitor pos 1,2,3 and monitor pos 2,1,3 and its recognising that as completely different setups and not the same monitors just in different positions.

Anyway, I don’t think I can make any further guesses unless I split the trailing IDs to try and figure out what they are, I suspect its some key for monitor position, saved setting and device ID.

@mc-lemons, maybe run the powershell command on your surface and see what you get?

@scottm8, @Ingenjoor, @cmmd_mx - any idea?


#22

Ok can confirm: yesterday the device went to sleep/hibernate (forgot to shutdown which is what I usually do), and today it resumed with the correct settings after logging into Windows profile.

The login screen was duplicated screens.


#23

Windows multiscreen is not very good implemented:

  • if you change rotation of screens one way, and then back again, windows doesn’t restore the icons correctly on both desktops, doesn’t restore the “angle” between the screens (puts them “to the left/right” of each other instead of "left/right up corner)
  • if you disconnect 1 screen with icons and then connect it back again it doesn’t restore the icons on it
  • if you take a fullscreen window (chrome for example) from V screen and drag’n’drop to the top of second screen (so as to “snap maximize” the window) it actually is not maximized correctly
  • all sort of other weird glitches.

Windows is all around not polished enough.


#24

Sorry for the delay. My IT department decided to re-image my Surface, since there were too many issues with it that had them baffled (none related to anything we have been discussing here). So I wanted to make sure I had used it with my Surface Dock at work and my Plugable Dock at home before running the powershell command. However, I did run the command right after I got it back, before plugging in any external displays, just so we’d have a base line. The results are below, and as expected, the only display in the list is the built-in display

Initial Run
Class Name Present DeviceID
Monitor Surface Display True DISPLAY\SDC3853\4&3B1D693F&0&UID265988

And below is the run I just did today, after a handful of connect/disconnects to the docking stations at both work and home.

Run after some use
Class Name Present DeviceID
Monitor Generic PnP Monitor False DISPLAY\ACR0523\4&3B1D693F&0&UID200195
Monitor Generic PnP Monitor False DISPLAY\ACR0523\4&3B1D693F&0&UID208387
Monitor Generic PnP Monitor False DISPLAY\EXN0000\4&3B1D693F&0&UID206395
Monitor Generic PnP Monitor True DISPLAY\GTW037B\8&FE9D565&0&UID256
Monitor Surface Display True DISPLAY\SDC3853\4&3B1D693F&0&UID265988
Monitor Generic PnP Monitor True DISPLAY\TAL1702\8&FE9D565&0&UID257

The ACRs are my two Acer Monitors I have at work
I’m guessing the EXN is when I plugged my Surface into one of the TVs during a meeting I had last week
The GTW and the TAL are as mentioned in my above post

So, this list actually doesn’t have any duplicates of any of the displays.

All that being said…the issue is now resolved. I can’t say exactly for sure what fixed it, but I have a pretty good guess that it was a piece of software that was somehow interfering. I run a multi-seat software called Aster (http://www.ibik.ru/), and I started wondering if it could somehow be causing the problem. I initially thought about uninstalling it, but then found an update on their website. I installed the update and the problem was gone. The only reason I’m not 100% sure that was what was causing the issue, is because I didn’t test to see if the issue was still present directly before I upgraded Aster. And with all the different things I was trying (drivers, Windows Updates, etc), there’s a chance that maybe something else fixed it. But like I said, it seems most likely that it was some conflict with Aster.

Sooooo horay! My V now remembers all the different setups I have tried with (probably tested 2 or 3 so far).

Unfortunately though, my CalDigit docking station is still a very expensive paper weight. I’m still having the issues with it where it won’t stay connected and will connect/disconnect on and off, usually until the computer freezes up. I tried researching issues with Thunderbolt 3 docks not connecting, but all I really found was to ensure the below:

  • Update the Thunderbolt software on your Thunderbolt 3 host device.
  • Update the Thunderbolt controller NVM firmware on your Thunderbolt 3 host device.
  • Update the Thunderbolt controller drivers.
  • Update your motherboard BIOS or UEFI.

Can anyone confirm if our Vs are running the most current Thunderbolt software, firmware & drivers?

Below is what my device has:

Thanks for all the help thus far!


#25

yep - sound like a standard windows troubleshooting story to me: try a bunch of crap, nothing works, then somehow problem goes away for no apparent reason. another problem solved!

anyway - about the TB3 details, slight difference in mine:

image


#26

Looks just like the only difference is the NVM Firmware (20.00 vs 29.00). But even though we matched on the other items, how do we know they are each the most current version? Intel’s website doesn’t seem provide any most current version information, just a page that says to check with your device manufacturer (https://thunderbolttechnology.net/updates) to make sure you have the latest. Sounds like we would have to wait for Eve to release something in their driver downloads section?

Sorry for all the questions. This is my first Thunderbolt device, so I’m pretty green on how it all works!