KDE Plasma resolution scale of 200% causes desktop background to be 1/4 of the screen at login with ES07D03 using HDMI 2.1

I have reported this to KDE:

https://bugs.kde.org/show_bug.cgi?id=453012

The monitor’s HDMI compatibility mode amazingly made this issue go away, so I am not sure if it is an issue in the monitor itself. I am mentioning it here for anyone else with the same problem.

1 Like

Hey there!

Glad to see a fellow penguin here on the forums! I’m also a big fan of the KDE desktop environment and I use it on a daily basis so I might be able to help. Funny enough, I’ve had a similar issue when plugging my system into the TV in my living room, which is a 4k display and really messes with my desktop environment. Can you give us more info on what kind of system you’re using:

  1. Your OS
  2. Are you using the spectrum 4k?
  3. Kernel Version
  4. Monitor firmware version
  5. Your GPU/hardware details
  6. Does it behave the same way when you use a different display?
  7. What have you tried to fix it so far.
  8. Have you tried booting with Wayland?
  9. Have you tried a different environment (if you have them set up) like Gnome, MATE…
  10. Do you have a windows system available to you (in case we need to update the firmware on your monitor)
2 Likes

Neat. Are you using KDE with the ES07D03 and HDMI 2.1?

Also, to answer your questions:

  1. Your OS: Gentoo Linux (testing branch called ~amd64)
  2. Are you using the spectrum 4k?: Yes.
  3. Kernel Version: 5.16.14-gentoo-x86_64
  4. Monitor firmware version: 106
  5. Your GPU/hardware details: GeForce RTX 3080 (ROG-STRIX-RTX3080-O10G-GAMING) (running VBIOS v5), Asrock B450 Pro4 motherboard (running BIOS version 5.00), Eve Spectrum ES07D03 144Hz 4K monitor (running scaler firmware version 106)
  6. Does it behave the same way when you use a different display? I do not have another 4k display to use to test.
  7. What have you tried to fix it so far.: HDMI compatibility mode makes the issue go away, but then I do not get 144Hz. I have tried different HDMI cables. I have also tried updating Gentoo to the Gentoo testing branch (~amd64) to get the latest KDE software. I have tried turning off VRR. Nothing has worked aside from compatibility mode.
  8. Have you tried booting with Wayland?: No, because I cannot use VRR with Wayland and Nvidia graphics.
  9. Have you tried a different environment (if you have them set up) like Gnome, MATE…: No. I do not have them installed.
  10. Do you have a windows system available to you (in case we need to update the firmware on your monitor): I can arrange something if necessary. That is how I got to scaler version 106.
1 Like

Ahh, Gentoo users are hard to find. it became my distro of choice back in the day before I migrated back to Windows - for gaming, mainly, let’s be fair.

I haven’t used a modern distro with modern hardware, but I am atempting to set up a couple of Gentoo VMs in Hyper-V (one gen 1, using GPT + emulated BIOS and one gen 2, using GPT + UEFI), in my spare time, just to see if I can get it fully working in a fully dependent VM environment.

I’ll be following this thread closely as I’m toying wit the idea of throwing Gentoo on this rig and running Windows in VMs on it, as well as having bare metal access for Window son the few times I actually want to game in Windows.

Getting back on topic - what happens if you decrease scaling to under 200%, does that 1/4 res wp finally go away, or just get a little bigger? If it goes away, if you bump back up to 200% does it reappear, or only on the next login attempt?

It is not hard for me to find Gentoo users, but that might be because I am a retired Gentoo developer. :slight_smile:

Games on Gentoo are much better now thanks to Valve and Lutris. Valve did plenty of work to get games running on Linux and Gentoo benefits from basically all of their work. Lutris makes installing non-steam windows games fairly easy and does workarounds to fix known issues as part of their install scripts, although this does not stop people from accidentally turning off workarounds via in game settings (ignore any windows guides that say to run overwatch in full screen mode).

We recently got support for Apex Legends thanks to the developer adding EAC support for the steam deck. There is some stutter from shader compilation occurring late due to differences between Vulkan and Direct3D, but I have been maintaining a DXVK cache file that fixes it:

I also have an issue where the monitor does not detect a video signal after turning it back on after being off while the machine is idle. I have been working around it by doing Ctrl+Alt+F1 and then Ctrl+Alt+F7 to change virtual terminals. I had not reported it yet since I am still trying to figure out whose bug it is. All I know regarding this right now is that the wake-up issue does not occur when I have a copy of Windiws booted off a USB key.

There is yet another issue where SDDM gives a black screen at login when VRR is enabled. It is possible to fix it by modifying Nvidia’s application profiles rc file to disable VRR on sddm-greeter. I have emailed Nvidia with this information so they hopefully will be adding that fix to their driver in the future.

A 3rd issue that is not specific to the spectrum is that Valve remote play is broken with Vulkan games when the host resolution is above 2560x1600 on Linux:

A workaround is to set the games to use windowed mode at a resolution of 2560x1600 or lower, but it is annoying.

A 4th issue is that pasting screenshots to discord (in chromium) from KDE does not work for 4K images. This appears to have been fixed on my machine by switching to Gentoo’s testing branch, so I suspect that KDE 4.24.4 fixes it. Gentoo’s stable branch still uses KDE 4.23.5.

A 5th issue is that programs run in wine (or proton) do not honor KDE’s scale setting. I find that I need to open wine-config manually and set the DPI to 144 to get things like blizzard’s launcher to not be absurdly tiny.

If you try Gentoo with the Eve Spectrum, keep an eye out for those issues. All but the first of those issues are not issues for Eve, but I am not sure yet about the first one.

Surprisingly, it does not go away when I lower the global scale to 100%. I posted this in the KDE bug report too. The black area only goes away when I restart plasmashell via plasmashell --replace (typically through Alt-F2) after logging in or when I login with the monitor in compatibility mode. When I restart plasmashell, I actually have two desktop wallpapers appear when the desktop is not in focus, with one being 1/4 in size. I must then restart kwin to make that disappear. A screenshot of that is also in the KDE issue.

Here are direct links to the screenshots:

https://bugsfiles.kde.org/attachment.cgi?id=148364

https://bugsfiles.kde.org/attachment.cgi?id=148365

3 Likes

After thinking about it, I think this one is probably something that Eve should take up with Nvidia given that their monitors are supposed to be gsync-compatible. There is probably something in the Nvidia Linux driver that needs to be changed to detect the monitor going back on.

1 Like