Intense flickering on monitor on all my devices, even after firmware update

Not even 24 hours of having this monitor and this flickering started happening. It’s damn near impossible to ignore rendering this monitor useless to me right now.

I’ve already ruled out that it’s not a cord issue (used 3 other cords, same problem) and 3 separate devices. The monitor never stopped flickering. Even when you turn the screen on and the eve triangle pops up, it has small lines running through it. I’ve also updated the firmware from 102 to 104 to no avail.

Honestly, I’m mostly using this post to vent and scream into the void because I can’t express how upset I am after waiting 5 months (after purchase, not preorder, that wait was like 1 year ago) to get this monitor and it became an oversized paperweight in under a day. I’ve already contacted support, who knows how long it will take to hear back from them, but if anybody has advice I will gladly take it.

P.S. The monitor I have is their top-of-the-line one, 4k 144hz.

2 Likes

Hey @Amy_Gad,
Really sorry to hear you are experiencing issues with your Spectrum. I’ve sent you a private message asking if you could provide your support ticket reference number, and I’ll get the team to look into this as soon as possible.

Is it similar to my issues?

Eve support have acknowledged the monitor is faulty but I’m waiting for further response. I want them to send me a replacement before I send the faulty display back because, as you’ve already highlighted, shipping is a total pain. My display does actually work in certain configurations but not the ones I want to use it in.

1 Like

I don’t think it’s quite the same. I couldn’t get it to go away on any setting I tried so I’m under the impression it’s a hardware malfunction. I’m really hesitant about getting a replacement because of the inevitable wait time AND the risk of something like this happening again. I’m still processing the whole ordeal to be honest, so it’s hard to say what I’ll do. :sweat_smile:

1 Like

Wow after messing for a while with mines I got it fixed, I turned off adaptive sync on my monitor and the flickering went away