I Need to Unplug Monitor Before Use

I love my new Spectrum. I have model ES07D03, firmware 104.

Almost every time I turn on my laptop or Xbox Series X, I have to unplug the cable from the power box, wait 5 seconds, and plug it back in for the monitor to work. I can’t just use the power button on the monitor.

It works fine all day after I do this, but every time I shutdown and come back the next day, I have to do this again. I have no other problems with the monitor. It’s fabulous, but this one issue is annoying.

Is this a known issue with a known fix? Thanks in advance for any assitance.

1 Like

Some users are experiencing an issue where their Spectrum won’t wake up from sleep. Can you provide a bit more detail and we can try figure out if you are experiencing this wake from sleep problem or something else.

First, do you power off your Spectrum or let it go to sleep? If you are letting the Spectrum go to sleep do you still have the problem if you power the spectrum off?

How are your Xbox and laptop connected to the Spectrum. Are they both connected at once? What port are you using for each? What cables are you using?

And welcome to the community! You’ll find it a helpful and friendly place.

1 Like

Thank you, Taalyn. I power off my Spectrum using the power button on the Spectrum. I have the laptop and the Xbox both connected to the Spectrum, one on each of the HDMI ports. I’m using a standard HDMI cable for my laptop and the HDMI cable for my Xbox that came with the Xbox.

I generally have it on all day during work without any issues. I can switch between both my laptop and Xbox without issue. Once I shutdown for the evening, I have to unplug and plug back in the next morning to get it to work again.

I do power off my laptop and Xbox, then power off my Spectrum using the power button on the Spectrum.

This doesn’t sound like its related to the wake from sleep problem. I should have asked the first time but - what laptop are you using?

I also assume the Xbox cable is plugged in source end to source and display end to Spectrum since you said the Xbox works all day.

If you power off the laptop and Xbox but power them back on before turning off the Spectrum do you get signal back?

Can you test and if you still have to unplug the power when:

  • plugging in only the laptop,
  • plugging in only the XBox, or
  • using a different HDMI cable if you have alternate cables them, or connecting the laptop using the Xbox cable?

Sorry for my delay. I will check and test what you stated. I can confirm I do not get signal back if I turn off the devices but don’t turn off the Spectrum.

Happened just now again. I had to unplug it to get my laptop to work after turning it off and on. It’s a ThinkPad.

What model Thinkpad?

ThinkPad Model 20NYS3DU00.

Have exactly the same issue and already wrote support about it. I have that issue with my Xbox Series X and every MacBook I tested. MacBook Air M1, MacBook Pro 16" (intel), MacBook 14" (M1 Max). All MacBooks where tested with the latest Big Sur and lately every release of macOS Monterey.

The monitor is on (backlight on) but doesn’t display any video signal. Have to unplug it from power, plug it back in. Then it’ll show a display signal. It’s super frustrating because it makes the whole experience annoying.

Once the Mac goes into sleep its a hit and miss if the monitor will wake up with it again or if I have to unplug it from power. Apparently this wasn’t addressed in the 105 firmware.

1 Like

I’ve experienced the same thing.

MacBook 14" M1 Pro.

I’ve now resorted to having the displays turn off NEVER and using a screensaver for those times that I’m away. Yes, this will lower the lifespan of the monitors, but I can’t afford to be fiddling around for a few minutes or having to deal with the uncertainty of knowing whether my monitors will work before online meetings.

@Schnurnado Definitely sounds similar! Are you also connected to the two HDMI ports on the Spectrum? On the MacBook side are you using the USB-c ports only or HDMI where it is available?

@ChadCottle Do you see the same thing as Schnurado with the backlight on but no video signal? If you haven’t already - can you please create a support ticket (Support – Eve).

If you could both give me the ticket numbers via private message I’ll touch base with the support team and let them know these might be related. Include as much detail as you can in the ticket and private message - particularly the HDMI port modes and what cables you are using.

Add me to the list of people with this issue. I’ve got a late 2019 MBP, Intel, 15.6" with Radeon 560X graphics.

Under v104, I would have relatively frequent trouble getting the Spectrum to come back on when my MBP woke from sleep. What I saw was:

  • The Spectrum would go through the motions of waking up.
  • The MBP would think that it was displaying things on the Spectrum.
  • The Spectrum’s backlight was on, but it only displayed a pure black screen.
  • It was not possible to bring up the OSD on the Spectrum. Clicking the stick did nothing.
  • The power button on the back of the Spectrum was unresponsive. The only way to turn off the Spectrum was to disconnect the power.

I haven’t tested things on v105 yet because I’ve been turning the Spectrum off every night. I’ll try letting the Spectrum go to sleep over the next few days and see if the issue reoccurs.

Now that sounds like the wake from sleep problem. We would love to be able to track the cause of that one down! I can’t see a common thread - it doesn’t seem to be related to a port, a cable type, a cable brand, an OS, a graphics card, a firmware version, …

@ChadCottle seems to be having the same symptoms but before the Spectrum goes to sleep. Do you lose video signal if you power off the device and turn it back on or only after it goes to sleep?

I am collecting details on configurations for the wake form sleep problem - Monitor unable to wake from sleep sometimes - #21 to help the team find the root cause. If you add your configuration to the list I will keep collating the info.

Yes, Schnurado’s experience is exactly the same issue I’m having. I also have resorted to using a screen saver to keep it active so I don’t have to unplug it.

I do lose video signal if I power off the device. I always have to unplug the monitor when turning on either device.