How to disable DSC on Spectrum 4K?

I’ve figured it out it’s that the other LG monitor is basically the exact same (text looks horrible on Windows 10) except I can disable DSC on it. When I enable DSC on the LG it causes the exact same issue as my spectrum. I’m trying to use the spectrum instead of my LG GN950B but I can’t find the option to disable DSC in the settings so I can at least do 4K 120? My 1070 isn’t compatible with it and it causes issues when it’s on. My previous LG had the option to disable it.

1 Like

I’m interested in knowing what you mean by your 1070 not being compatible with DSC?

I also have a 1070 and I’ve noticed some weird blurriness around sharp lines and text when running above 60hz, for both HDMI (2.0) or DisplayPort (1.4). I’m wondering if you’re seeing the same issue or a different one?

1 Like

Is your problem/situation something like this? https://www.nvidia.com/en-us/geforce/forums/game-ready-drivers/13/415422/display-stream-compression-buggybroken-in-drivers-/?topicPage=5

According to that thread, driver version 465.89 (released March 30) fixes the DSC issue.

@salzar have you updated your drivers recently? If not, try grabbing the latest driver update and see if that makes a difference.

2 Likes

I’ve tried both upgrading drivers as well as ClearType tuning and neither helped.

Here’s a picture showing the difference. You can see the weird chromatic aberration effect (the red and blue tinges around the text edges) that shows up at 144Hz. This disappears at 60Hz and text is just grey as it should be.

Here’s another example, taken from the actual ClearType tuner UI. You can see how the 1px border line around that UI control has become smeared with a blue tinge at 144Hz, whereas it’s crisp at 60Hz:

1 Like

That is the exact issue I am having, it has to be added into the firmware by the team, they’re currently working on it right now contacted Spectrum support.

That is the exact issue you’re experiencing, the 1070 doesn’t has DSC support so it’s causes your text to appear multicolored blurry and jagged, it’s supposed
To be doing lossless compression but it’s not lossless cuz the 1070 doesn’t support it. I have another monitor by LG which pretty much the exact same panel and when I disable DSC on it the exact same issue goes away. There’s currently no option to do so on the spectrum so we’ll just have to wait for a patch to come out for the firmware. Also turning it off limits you to 4K 120, no 144hz, but you get full RGB and HDR.

3 Likes

Ah, interesting, so this is a limitation of the Geforce 1070! That’s good to know (too bad it’s a terrible time to buy a new graphics card :sweat_smile:). Let’s hope the firmware can be updated.

3 Likes

Yep! They should be able to do it no problem just will take a little time.

1 Like

Based on your photos, the 4K@144Hz case looks like there is chroma subsampling such as 4:2:2.

2 Likes

According to @salzar, this is caused by my GeForce 1070 not actually supporting DSC.

2 Likes

Not mutually exclusive. If DSC is not supported by the video source, but the bandwidth is limited anyway, chroma subsampling (possibly implicit) is basically the only way to fit into that limited bandwidth.

3 Likes

It sounds very much like lack of DSC + chroma subsampling is the cause of this.

I found an article on chroma subsampling that explains exactly what’s going on here.

If we assume that 4:2:0 subsampling is being used, 21.52Gbps / 120 * 144 = 25.83Gbps. This just fits under the 25.92Gbps bandwidth cap for DP1.4. 4:2:0 subsampling effectively means that each block of 2x2 pixels will share a chrominance (colour) value. This makes it very hard to get accurate colours, and there will be a degree of colour bleed on surrounding pixels.

I’ve double-checked and the GTX 10XX series has DP1.4 support but without DSC. You need a GTX 16XX / RTX 20XX / RTX 30XX card in order to get DSC support.

Because this is a hardware limitation, it looks like the only options here are:

  • Disable HDR. You’ll be able to run 4K@144Hz, you just won’t get the same richness in colours.
  • Run at a lower refresh rate, e.g. 90Hz. You’ll get the nice colours, just without the frame rate boost.
  • Live with the colour issues.

Moving to HDMI won’t help because it’s got even less bandwidth than DP1.4 does.

7 Likes

I’m currently running at 60Hz so my text doesn’t look terrible. Unfortunately it seems like 90Hz isn’t an option, I can only jump from 60Hz to 100Hz. That’s okay though, I bought these monitors expecting their capabilities to exceed my PC’s capabilities, and for me to grow into them when I eventually upgrade. The reality is that my current graphics card can’t produce 144 FPS in most games anyway! Right now I’m just enjoying the crisper high DPI text and lovely brightness and colours compared to my old monitors.

My problems with the monitors not going into standby mode properly are more of a concern for me, but I’m hopeful that will be resolved with a future firmware update. :pray:

1 Like

@NZgeek I should be able to get 4K120 hz with full RGB 8 bit color depth. I just need to disable DSC. I might request to return this monitor and buy another LG at this point because the LG I have has that option to disable DSC and runs at 4K 120Hz no problem with great colors on my 1070. This should’ve been a feature in the firmware at launch.

@MT How come when I disable DSC on my LG I get 4K 120Hz Full RGB

Either it’s not true RGB, or the issue with Eve Spectrum is not that the video card does not support DSC. Or maybe DSC is only needed at 144 Hz and not needed at 120 Hz — then you can probably use Eve Spectrum at 120 Hz too instead of 144 Hz.

1 Like

I believe 4K 120 works without DSC, because the colors are significantly better than chroma sub sampling. 10 bit is not an option but I can live with that