Horrendous blue burn-in and flickering at 60HZ

This is extremely concerning, I viewed https://www.reddit.com/r/Monitors/ for all of a few seconds and then noticed the blue areas burned into my screen when displaying greys.

Here’s a photo: Eve Spectrum Burn-in · CleanShot Cloud

And then while trying to figure out what was going on I switched from 144HZ to 60HZ and the screens flickers like crazy, this never happened with 60HZ before.

See this video: Eve Spectrum Flickering and burn in · CleanShot Cloud

I’m using a USB-C connection (Thunderbolt 4 cable) with an M1 MacBook Pro. I’ll be emailing support also but wanted this here in case anyone can help soon.

1 Like

Hey @Yep

Sorry to hear you are experiencing this issue with your Spectrum. You did the right thing in contacting our support team. Our support team will provide you with assistance for this issue you are experiencing. I’ll also try to find out more information from my side.

2 Likes

Between posting this and it being approved I’ve discovered that turning off “Low-latency Mode” while at 60Hz stops the flickering, but I could have that enabled previously at 60Hz.

I can also provide a better video if necessary, the example above is too compressed to see.

[edit] Also I can say that the image retention faded away after about 45 minutes, but this still worries me.

Another update. Just got a PS5 and tried it out via HDMI port 1, at 60Hz with Low-latency Mode enabled there’s still flickering.

I’m not sure at all what’s happened to cause this :frowning:

I’ll try and find a way to upgrade the firmware but without a Windows PC I’m pretty stuck.

1 Like

Hey, @Yep!

Would you please let us know if ‘Backlight strobing’ is enabled in the ‘Performance’ menu of the OSD? When backlight strobing is enabled at 60Hz, it is likely to cause visible flickering due to the relatively long backlight-off time between the pulse periods.

BLS is definitely disabled.

[edit] Now this is interesting, since connecting and using the PS5 over HDMI, when I switch to 60Hz using my MacBook over USB-C there’s no more flickering!

No more flickering with the display+MBP+USB-C, still flickering on the PS5.

Curious :thinking:

1 Like

Thank you for sharing the insight! We’ll look into the PS5 60Hz flickering and burn-in behavior of your Spectrum. In the meantime, if you observe any new behavior, please don’t hesitate to let us know.

1 Like

Thanks. I can add that the I believe the burn occurred when I was viewing the Monitors sub-Reddit (with the blue color theme) and at the same time changed my display brightness from 70 to 100 in one go (holding button down).

Maybe that’s relevant?

1 Like

Any related detail can be relevant. :grinning_face_with_smiling_eyes: We appreciate the additional info.

1 Like

I am pretty certain the 60Hz flickering has gone since I connected the PS5. It was unmistakable, if you click download and then download again at this link iCloud you’ll see it in slightly better detail.

1 Like

Could you please also help me

I have been with severa mails with Support since july 23.

Yellow stripe
No HDR
NO HDMI connectivity

81 DAYS without a solution and still waiting

1 Like

I’m also affected by the “blue image retention on grey backgrounds” issue.

All it takes is 1 min of displaying white content for the image to retain. It then takes about 30 minutes for the image retention to fade away.


Here’s a video of the issue in motion: https://i.imgur.com/zIEPGnJ.mp4

I ordered two Spectrum’s, and only one has the issue. The issue is reproducible regardless of the device, cable, or port used. The issue has been present since day 1.

I’m pretty sure this is a hardware issue (bad panel that should not have passed QC) and will require a replacement.

I have already contacted Eve support, but I’m also posting here for visibility. I’m wondering how widespread of an issue this is.

Note that I don’t have the flickering issue mentioned by OP. These appear to be independent issues.

5 Likes

Out of interest what do you have your brightness set to?

1 Like

I put it at max (100) when recording this video, since it’s the easiest way to reproduce the issue.

I normally use my monitor at around 50 brightness though. I still get an abnormal amount of image retention, just not as extreme as when it’s at 100.

With my other (non-defective) Spectrum, I can’t cause any image retention, even at max brightness.

2 Likes

Wanted to chime in that I’m also experiencing the burn-in and constant flickering and blackouts. I left Steam open for a couple of hours and now I also have the image burnt into my screen. It’s been a rough experience with this monitor, especially after paying over a thousand CDN for this. I’ve been experiencing screen flickering, blackouts, and now burn-ins.

1 Like

Eve support weren’t very helpful but I’d advise emailing them with as much info as you can so they’re aware of the problem. Hopefully they are passing it on to the relevant people.