HDR Question, not getting bright?

I updated the fireware, i turned on HDR in windows settings. I didnt notice the screen getting any brighter. I was just using a Acer Predator XB3 and as soon as i turned on HDR on the monitor. Everything was so much brighter. Not sure if i have a good monitor. Is there something im not doing right? Im using a Digital Port and have used the HDMI 2.1 also with my 3080ti

Try watching this video. Turn HDR on/off and you’ll definitely see whether it’s working or not.

So the first one is with HDR on

And second is with HDR off

So I kept going back and checking it and I was getting the first one over and over again with HDR on

The big test for me is the first shot in the beach. Look at the clouds at the upper left corner.

With HDR off, the clouds look white. With HDR on, the clouds look WHITE.

That, to me, tells me that HDR is working correctly.

cant really tell the difference in the video, but i can on my desktop wallpaper little bit

I can’t get HDR to work on windows. But my other monitor (LG) works just fine. Any suggestions

I think that the colours going funny in the video are because it has levels of brightness and darkness that aren’t able to be represented in non-HDR mode.

On that first scene, the sky should be really white compared to the YouTube background, which is a just very slightly off-white.

Here’s what I’ve done, in case any of this matters:

  • I updated my Spectrum’s firmware to 102R875. I don’t think this is factory installed, and even if your firmware shows as 102, it’s older.
  • I’ve got my Spectrum hooked up to my RTX 2070 via a DP cable. The cable is rated for 8K video.
  • The HDR option shows up in Windows display settings after I select the right monitor.

It’s worth noting that your graphics card plays a big part here. Only very recent cards can do 4K and 144Hz and HDR, because it requires support display stream compression (DSC). On the Nvidia side, only the GTX 16xx and RTX 20xx/30xx cards have the necessary support. I don’t know about the AMD side of things.

If your card doesn’t support DSC, you’ll have to live with either a reduced resolution, a reduce frame rate, or no HDR. There simply isn’t enough display bandwidth to support all 3 at the same time.

1 Like

Yea I hear you, like I said. Only thing that has me thinking is that the acer that I been using for the past week is a lot brighter in hdr and this monitor is suppose to be a lot better. Idk maybe I’m over thinking it :man_shrugging::man_shrugging:

I’m running a gtx 1080. My lg 4k 60hz display has no issue doing it. The spectrum does. I have noticed that there is no color profile for the spectrum though. Does this have anything to do with it? I have updated to the most recent firmware as well.

The 1080 supports DisplayPort 1.4 but without DSC. You need DSC to get 4K@144Hz with HDR. Without DSC, you can get 4K@144Hz without HDR or something like 4K@95Hz with HDR.

It’s possible that the HDR toggle has been hidden because HDR isn’t possible with the refresh rate you’re using with your Spectrum. If you set your refresh rate to something below 95Hz, the toggle might show up.

There is one other option available, and that’s 4:2:0 chroma subsampling. This basically throws away some color information in order to save bandwidth. Unlike DSC, which is designed to be visually imperceptible, chroma subsampling will cause some kids in color accuracy. It’ll be most noticeable in areas with fine detail and high contrast, such as dark single pixel lines on a light background.

Interestingly, other people here with 10x0 cards did get the HDR toggle and chroma subsampling was enabled automatically. I don’t know why yours hasn’t done this. Maybe it’s a driver thing.

1 Like

Its there but every time I make that switch it snaps back to off.
I have tried different resolutions as well.
I will try a fresh install of windows to see if this addresses the issue.

It sounds like Windows is trying to set HDR mode but it’s failing. That’s why it said back.

One thing you could try is to look at the Nvidia Control Panel and go to the color settings for the monitor. There’s some advanced color settings you can try, which might allow you to manually enable 4:2:0 mode.

1 Like

Well That didn’t work either. Maybe the 1080 just doesn’t allow it.







so i put the Acer side by side and the acer is brighter. How is that possible??

What is the brightness setting on the monitor OSD itself on both? I’ll try increasing it on the Eve Spectrum.

I keep my current Samsung LU28R55 on 70% because otherwise its too bright.

I’m going to try that when I get home. I’ll see what it’s at


Doesn’t let me get to brightness… only sharpness :thinking::thinking:

ok, i changed it in nvidia settings.

im not sure if it hits 600 but it definitely gets really bright

hello, so to conclude, what settings do you recommend to have good HDR and good brightness?
i will receive my unit soon and i want good settings for my spectrum
thank you!