Goodix fingerprint scanner - not working


#101

I’m having the same error code myself :frowning:


#102

Yeah… i think most of our fingerprint scanner broke because of a windows update


#103

Yes, I get that too (thanks everyone who helped me find the latest driver. Given that my fingerprint reader became gradually unreliable before it stopped working I do suspect a hardware fault.


#104

So there is no real sensor fail.


#105

Google shows recepies (for the courageous between us).


#106

Mine refuses to work upon boot. But when you login, hit the on/off button and then wake the device again, it works.
Once the device needs to wake from a deep sleep, it refuses to work again…

I’d definitely say it’s a driver issue / Windows update incompatibility.


#107

I have a faulty reader too - mine shows error 43.
I was not able to install any driver from the ms update catalog for Goodix, seems the firmware requires an oem driver.
Btw lol, i was not in the forums for 1/2 a year, reading the latest posts now - wow, what a deja vu, folks ordering systems in Dec still not have them and surprise, the same oddballs of die-hard fanboys still accuse the complainers of whining.
Seems Eve put on a Ponzi scheme by trying to cover the red numbers from the Indiegogo campaign with the sales that started last year - btw. before our units shipment - maybe they even needed that cash to ship the Indiegogo stuff …
Boy what sane person would still put up a fight for them?
Guys from EU, if you have reported this issue already and they did not solve it, there is a maximal duration per law in which they have to offer a solution - is 30 days for me, may be different for you. If its past that i recommend you to involve authorities and ideally open a case through the EU consumer protection portal against their Finnish company (for myself i participated in the Indiegogo campaign due their claims to be a Finnish company, their Chinese sister is just a fraud scheme to avoid legal issues if things go south).
If they wont solve the issue with the fingerprint i will do so exactly 31 days after i submitted my issue to them.
Hope they dont go into bankrupcy till then.


#108

I am being asked by the support to reinstall the OS, i assume all that have the same issue were asked to do the same.
Did someone do it and what was the outcome?


#109

Already tried and failed. If you still want to try I’d recommend backing up an image of your installation through a program like CloneZilla, which does it by a bit-for-bit clone of your installation and can therefore be restored after doing a fresh install if it doesn’t fix the fingerprint issue


#110

Same here - I haven’t had time to do so yet - it’s a fairly long process and it’s not really a sufficiently important issue until I’ve got lots of time on my hands.


#111

Im not happy to reinstall if it did not solve the issue by someone else who did, as that indicates a hw failure.
Im trying to download the image and will try to do the install in a virtual machine.


#112

EVE support answered of one of my requests.

This solution did not work for me, but maybe for one of you?!

Here is a older driver version for the goodix fingerprint sensor:

https://evet1.sharepoint.com/:u:/s/EveTeam/EcqvIuI_xMNInB-EZEtMTjcBfuykua34x-OmQeUoZpNTiA?e=HIdxVX