Goodix fingerprint scanner - not working


#21

The warning sign in the Device Manager normally means that the device is detected, but the driver has some error.
That results in the sensor not working.
As @SyrtakiVampir explained: uninstall by ticking the box that removes the driver completely and do a V-restart afterwards.


#22

I’ve been having the same fingerprint reader failure and was involved with a long thread on this forum with lots of technical info. But the thread disappeared. Amazing. Disappointing. Support suggested a reinstall of windows. Equally disappointing. I’ll live without the fingerprint reader.


#23

Thanks I was given the same advice…


#24

I have the same issue, my device has had the warning icon for a long while, but the sensor sitlll works.

I think that’s the problem, its not consistent enough to actually pinpoint the problem in order to solve it.


#25

Same here. :hushed::confused::flushed::disappointed: it only happens from time to timd for me since the 1803 update


#26

@kicker
Here is the thread you where reffering to (long live Google Cache :wink:


Fingerprint Sensor stop working
Support
V | Hardware
amibert 2018-03-22 10:46:57 UTC #1
Hi, the fingerprint sensor of my V i7 suddenly stopped working. The device manager tells me that the device was stopped because of an error (Code 43) … what ever that means.

First I reinstalled the drivers, didn’t help.
Second I deinstalled the device in the device manager with deleting the drivers, reboot and reinstalled the drivers, doesn’t help either.
So any idears to solve that issue?

cheers
Danilo

hiddenflaw 2018-03-22 11:23:04 UTC #2
Deactivate and reactivate the device? Have you googled what code 43 error means? Also maybe you can try to verify the hardware is still working through programs like hwinfo?

amibert 2018-03-22 12:56:39 UTC #3
Yes, tried also deactivate and reactivate, still the same error. What oncle google told me so far is that it might be a driver issue. So most of the cases I found with that code was a driver problem but didn’t find a solution suitable for me.
Hwinfo might be an idear … but I see nothing unusual here.

Digging into the Windows Error Log show me the critical event-id’s 10110, 10111, 10112 (DriverFrameworks-UserMode) … just searching to find something usefull on the net …

Arrow 2018-03-22 13:05:17 UTC #4
Contact support :slight_smile:

Ludilu 2018-04-11 08:51:58 UTC #5
Mine stopped working today as well…
same error

Have you contacted support yet?

amibert 2018-04-11 17:39:42 UTC #6
Yes I have. They suggest to do a new install of the V via a provided image (to be sure if it’s a hardwarefault or not). I haven’t done that yet so I can’t tell you if that works or not. :wink:

kicker 2018-04-11 21:36:49 UTC #7
I have the same problem…
“Windows has stopped this device because it has reported problems. (Code 43)”
Goodix Fingerprint SPI Device. Driver: Goodix FP, dated 7/8/2017, version 1.0.20.27

At first I thought it might be related to yesterday’s Windows update, but looking back, I seem to recall my fingerprint login getting a bit squirrely a day or two before the update.

--------UPDATE-----------
Just found the Critical event in the Windows System Log:
“The device Goodix Fingerprint SPI Device (location (unknown)) is offline due to a user-mode driver crash. Windows will attempt to restart the device 1 more times. Please contact the device manufacturer for more information about this problem.”
Then, 2 seconds later…
“The device Goodix Fingerprint SPI Device (location (unknown)) is offline due to a user-mode device crash. Windows will no longer attempt to restart this device because the maximum restart limit has been reached. Disconnecting the device and reconnecting it, or disabling it and re-enabling it from the device manager, will reset this limit and allow the device to be accessed again. Please contact the device manufacturer for more information about this problem.”

Ludilu 2018-04-12 07:49:04 UTC #8
I found the same critical events in my windows system log as well.
The question is if it is an hardware issue or not.
I will see if i have time this weekend to revert my windows to an older state or reinstall.

Datcu_Octavian 2018-04-13 05:44:10 UTC #9
Same problem here. Did anyone solve this problem?

Wickedly 2018-04-13 10:26:47 UTC #10
wait - is the problem that the fingerprint reader isnt working, or that there’s an event in the event log?

i just noticed my fingerprint reader driver device isnt started in device manager, but its reading my fingerprint fine.

image

Ludilu 2018-04-14 20:54:28 UTC #11
well, the main problem is, that the fingerprint isn’t working and while investigating we found those critial logs about the driver for the fingerprint reader

now that there are some more people that have this problem at the same timepoint i don’t realy think this is a hardware issue, but a software incompatibility issue with a windows update or something like this…

AML 2018-04-14 21:19:33 UTC #12
Windows, oh Windows, …
This is the opening sentence of a well known Windows love/hate song. . . .

Wickedly 2018-04-15 05:47:17 UTC #13
Here, i found something! Put this in powershell:

Get-PnpDevice | ? FriendlyName -Match “goodix” | Get-PnpDeviceProperty

amibert 2018-04-16 11:20:00 UTC #14
Hm, don’t know how this powershell command should help me … yes it produces some information but thats all.


#27

I have the same issue, it appeared after the Windows spring creators update. Considering the fact there is more people out there and it appears for all of us in the same timespan (i.e. after a major windows update) I doubt it is a hardware fault.

Did anybody find a resolution or was offered one by support? Other then re-installing Windows that is, I’m not prepared to re-install my windows version (it will take me 1,5 days to get my machine work ready again and simply cannot be unproductive for that long).


#28

@borro … Kudos to you! Thank you for finding that deleted thread!


#29

Actually, the error appeared at my V before the update.


#30

@besenbruch Ah, ok. bit more complex then. Sorry for wrongfully assuming.
For me it fully aligned with the Windows Spring Creators update I installed last week (and I did push that forward for a while).

Did anybody actually perform a full re-install of Windows and can share the results?

p.s. I contacted support and will share response once I receive it.


#31

I reinstalled Windows with the factory image, support shared with me. It seems to me a little bit newer, because it is already 1709.
But long story short, the problem is still there… :confused:


#32

Thanks for letting us know.

I was always hesitant to completely re-install Windows due to the potential loss of the monitor calibration.

What did support suggest now that you are on a brand new Windows and the fingerprint scanner still does not work?


#33

I havent had the time to reply yet. I will do some pics (support asked for pics or video in the first place) and see what they are suggesting next.


#34

@ludilu tnx for letting us know.
I’m in contact with support as well and have been requested to share photo’s / video of the issue as well.
I’ll do so without re-installing windows so lets keep each other and other updated on where we go from here.


#35

Have not had this issue until this morning. Fingerprint scanner was working yesterday as normal but on start up this morning it is not.
Also, maybe related, I have the Microsoft start up windows screen pictures that change from day to day. This windows asks (upper right had corner) if you like this picture (yes or not a fan). This window is at start up before fingerprint scan or password request. Anyway. It is not longer working ie never asks if you like the pic. This also started (failed) this morning…

Anyone gotten any where with fixing this issue?

Latest updates are Windows Defender Antivirus 6/26 and 6/27


#36

Well. After rebooting several times this morning and checking for any issue with the FP scanner install.
FP scanner not working after reboots.
I decided to see if there were any windows update. There were.
Installed the following updates
June 26, 2018—KB4284848 (OS Build 17134.137) (Installed 10AM)
June 27, 2018 --KB2267602 (Windows Defender) (Installed 10AM)

After these two were installed and system rebooted the fingerprint scanner started worked again.


#37

I got the same problem. Started a few days ago out of the blue. I did a clean install from USB, but no dice. Same issue… Also installed all the updates.


#38

Only if i had the effort to a line of code in cmd that would update the goodfix driver every so often.


#39

i got the problem after the latest windows update
wtf :face_with_raised_eyebrow:


#40

I am scared now… I still have mine working but don’t know for how long…