Goodix fingerprint scanner - not working

Apparently correct:
uninstalled the unknown driver (quite funny because the system indicates there is no driver); restarted the V and unknown device disappeared .

I have got exactly the same driver, but it is not working…
This problem is really strange.

The ‘mysterious section’ of w10 lacks help options. :face_with_thermometer:

ikr. i’ve given up on the hope of a solution

I think the solution is out there but I don’t feel that motivated tbh

is there still no fix for the problem?

Nope, i think Windows does not support this sensor cause of security patches etc. and Goodix doesn’t fix this.

Or smth different. But its still not working.

Does this company even seem to acknowledge this issue lately or respond to anyone here about it?

1 Like

This just like magically happened? Think it might’ve been the latest 1903 Windows update? Can’t get that update to install for nothing!

1 Like

I’m also here to declare: “magic”.

I’ve had this Goodix failure on my V fingerprint scanner for weeks, if not a couple of months. Same Code 10 error as mentioned above.

  • Updating drivers did nothing as the error does not let you upgrade them
  • Updating to Windows 2004 preview also did nothing (3 days ago)
  • Contacting Eve support, with all this information and a link to this forum topic got me: Please run Windows Update and please reinstall the drivers from our site. Not helpful.
    UPDATE: Eve Support did get back to my after writing this to let me know “Goodix, the manufacturer of the fingerprint reader, has been difficult in helping to resolve the problem. We are not the only company that has had issues with Goodix and fingerprint reader support. We think it may be software-related.” … Which is something at least.

Today however, something strange happened… mid sentence writing an email my bluetooth controls crashed and the Bluetooth icon disappeared with a notice stating that a USB device had failed. Reinstalling Bluetooth drivers did nothing.

I opened Device Manager to find that Goodix was now working properly as far as Windows was concerned and Bluetooth was nowhere to be found. I did have a yellow alert on an unknown USB device though.

Next, I restarted the V (with no change). Then I went to Device Manager, disabled the unknown USB device, and then re-enabled the unknown USB device.

All of a sudden Bluetooth device listings reappeared in Device manager and Goodix Fingerprint scanner drivers remained functional. I updated the Goodix drivers to .600. Still listed as working.

I’m at a total loss as to what the hell is going on with all these drivers. But (for now): magic.

8 Likes

Please share the magic

2 Likes

That’s all I’ve got sorry. Does seem like clashing driver software though. It’s been a very strange ‘fix’.

3 Likes

Apparantly there are several newer driver versions at Microsoft Update Catalog
If you then sort on the “last updated” column, you’ll notice the 1.0.20.1000 version. Only 1.x.x.x versions are suited for this fp reader. The 2 and 3 versions are for different fp readers.
I’ve tested the 1.0.20.1000 version, but they don’t work on my machine. Meh.
It might help somebody else though.

fyi gxfp3200 is the device id.

Going technical and diving in below…

The actual reason the host process for the driver terminates is due to a fail fast condition in the driver. I found the confirmation in the generated WER reports at C:\ProgramData\Microsoft\Windows\WER\ReportArchive\AppCrash_WUDFHost.exe_{a lot of hex}\report.wer. The Exception code in that file is 0xC0000409 which is the code for STATUS_STACK_BUFFER_OVERRUN. The name is a misnomer according to Raymond Chen. He is a core developer on windows for a long time. Fun stories on his blog as well.

When I have time to dive in deeper and find something, I’ll let you know.

6 Likes

I appreciate your hard work!

1 Like

Anyone have any recent updates or progress with this? I recently have been working on getting my tablet back up to speed. I have the camera, sleep, screen dimming, and touch screen ghosting issues fixed, and all I have left is the finger print sensor. If I can get that working, I’d be all set!

Can you describe what you mean by touch screen ghosting issues? I’m wondering if this is what I’m getting or not.