Goodix fingerprint scanner - not working

10 days since the last post in this thread. So: any updates on the Goodix issue? @Konstantinos
I would like to have my fingerprint reader back. :sob:

3 Likes

I’m sure if a solution is found he’ll come quickly to us solus :slight_smile:
That said; if it is indeed a driver issue, I don’t see a fix coming from Goodix coming quickly. Driver development is hard. Very hard.

2 Likes

My fp code error is now 10

Have a 1TB Eve that Ive been using more lately after ditching my pixelbook.

My Fingerprint sensor is getting glitchy. As someone else pointed out, it’s especially problematic after reboot.

Hoping there’s a driver fix for this soon. Logging in dozens of times a day is really aggravating when the sensor glitches out.

5 Likes

genuine question. what would it look like if you weren’t really pushing them? You said on April 8th that you gave them a week to follow up. It’s mid may and you have no eta for a resolution. This is much better than the average eve timeline, but still well behind what a would be acceptable at a kindergarten. I realise this post will get deleted before you ‘see’ it, but how on earth do you expect people to take your promises seriously when this is one of your better outcomes? Why on earth should anyone trust you konstantinos?

Nah, don’t think your post will be deleted. Since you didn’t break any of the comunity rules are your complain is more than justified.

The thing here, is not a mather of trust in Konsta or not. He is not the one writing the code for the firmware. I had this problem with my Dell XPS 15 9570, and It took HP almost a year to update the firmware driver for the fingerprint sensor.
Goodix has to pinpoint the problem and release the new updated firmware, but they are not going to do it only for EVE, but for all their clients.

7 Likes

My V fingerprint reader stopped working during the initial logging in after shutdown of the V. But would work after that such as from a restart or wake up from sleep. The latest Windows update May 2019 fixed all the issues for me.

So what’s the deal with the FP reader??? Does anyone know how I can get the FP login option to appear again at the login screen? When uninstalling the driver to reinstall and see if that fixed it I had the box checked that said: “Delete the driver software for this device”. Is that why I no longer have the fingerprint option?

Shouldn’t be. Deleting that driver is essentially just doing a clean removable and should be allowed to be reinstalled in the next time you run the installer. I am still using the FP scanner that was shipped with the V and it still works. Currently on 1809 on Windows haven’t updated to 1903 yet.

1 Like

Is there a way to download the original FP files or installer? Any links?

Thanks

Perhaps fingerprint problem is related to bios?

1 Like

Not sure if there’s any point to pushing or following up on this but is there any news on the FP reader fix?

4 Likes

I guess that if we still don’t have any news, it is probably because Goodix still didn’t come forward with a new Driver… :frowning:

Hmmm, yeah. Crazy that a fix like this needs more than a year to solve. A minor inconvenience in the grander scheme of things but still…

Yea… It is kinda sad… That the supplier support is so bad.
Now Windows insider has the password less feature… And if we enable it, we cannot login.
Game over.

There is no fallback to biometric security?

1 Like

All of you that have problem with fp driver: try to reinstall Windows like I did. Fp works fine after that on latest win10. I downloaded the newest win10 iso, deleted particions, created new one, install from pendrive. This is hard hard reset and it helps jn my case.

1 Like

Thanks for the info. What exactly did this fix for you? Was your fp sensor completely not working or was it taking too many attempts to recognize your fp? Mine works on the 2nd or 3rd try most of the time, but sometimes it gives up and makes me enter my PIN. So I don’t know if it’s worth doing a hard reset, because from what I understand, that will mean some of the V-specific software and/or firmware will be lost, no?

I experience a completely not working FP reader. It is not recognised by Windows 10 anymore. So I think Arturs’ suggestions makes sense. But at the moment I have no time for this adventure…

I think there are two problems with the FP reader. The first relating to the driver and which some folks have been fortunate to fix by various Windows re-installations. The second, however, appears to be a hardware fault - and there are a number of us in this camp. Every time somebody posts a solution here which worked for them I’ve tried it, never with any success. I was also sent a “factory reset” image by support to reset my V back to its initial (FP reader-working) state. Still didn’t work :disappointed_relieved:

3 Likes