Ghost Touches When coming out of Sleep


#41

The ghost touches still happen even on windows 10 april update even if the V is not in sleep, just with the keyboard closed:


#42

It’s unlikely to be a Windows issue, I think it’s a hardware issue.

So here are the guesses I have:

  1. It’s a thing to do with he keyboard connector. Might be that the connection is discharging static and this is causing the touchscreen to register random touches. The only evidence I have to support this is that I recall a few pictures/videos where the touches are clustered in the lower middle part of the screen.

  2. Someone mentioned the possibility that the spontaneously cracking screens are due to the screen bonding process. Could be that this is also causing the ghost touches - random stress on the mesh layer registering as touches.

  3. Could just be a funky touchscreen.

Either way, nothing much that can be done on the user side. Bummer.


#43

Well… i still rarely get ghost touches… even thought they durasticly improved after the diver updates.


#44

Yep. you’ve already said that multiple times and i totally agree. keyboard is at fault.


#45

I don’t know if it is already mentioned here but I have noticed that if I connect dock and external display then close the lid (V goes to sleep mode) then I press external keyboard’s button (or press V’s power button) V goes to active mode and I can see tons of ghost touches.

So using closed V with two ext. displays is impossible.

Interesting is that when V is in closed state, then it is impossible to put it into sleep (using power button or windows start menu). It keeps to showing lock (login) screen. Altouhgt if there is lock screen, and I open and close lid, V goes to sleep perfectly.

Also if I close V then unplug dock, V wakes up and never goes to sleep again until opened and then closed.


#46

Ever since I followed the steps put out by Eve Team I’ve only had them occur maybe three times over (maybe) 2 months, however I do keep a smal microfiber cloth in between when I close my V.

Can Eve not make a setting that allows for the touchscreen to be disabled temporarily when we want to close our V? Like an additional “closed” mode, where screen is off, keyboard is off, apps are paused


#47

Shh, I just like to keep heaping blame on the keyboard guys. All the mental anguish caused by the shift buttons, y’know.

Also, I guess the new thing I had to add was that it occurred to me that maybe whatever is/was causing the spontaneous cracking might also be causing the ghost touches.

If the glass is bonded to the touchscreen mesh layer and there is some kind of stress on the glass, that might be a factor.

Not sure if I’ve said that before. Old age and stuff. Lol.


#48

Hey there, I was having these same problems sporadically and while having to reset to get rid of the ghost touches was annoying, my main issue was the V waking up and drinking battery/slow cooking itself when it was supposed to be sleeping. I even changed the setting so that EVERY input, power button, lid close and idle result in hibernation yet I still had constant random wake problems.

I dug around a windows forum for a while and tried a suggestion regarding wake timers that apparently got messed up on the surface with some update. I haven’t had a single wake since, albeit everything is still set to hibernate, but without the waking while shut, I also haven’t had a single ghost touch issue since I disabled the wake timer.

I don’t think this actually fixes the ghost touch issue, but I think it greatly reduces the circumstances that result in having ghost touches on your screen. It might not help everyone but it clearly solved the majority of my problems.

Instructions in this link https://www.tenforums.com/tutorials/63070-enable-disable-wake-timers-windows-10-a.html


#49

Hey @Team , would be a good idea to have a look at what Josc just added, it really seems to help.


#50

So nothing change in Eve V team. They know the issue and no solution for months, no status, no communication, no update. I really hate myself for buying V and trusting them.


#51

you are sure it is not a windows quirk?


#52

still loving the V - its a great device - but with a lot malfunctions.

As Konstantinos said in a News & Announcments Post:

Good question here. As for the design questions issues you mentioned are one offs. There were max 5-7 kickstands that broke, below 20 pen holders broken, few cases of GPU issues and few occasions of the cables making noises outside of the standard. Those are really rare cases that are hard to catch during the QC as they appear after device used for some time. My point is that it is extremely you will get a device with such issue

i got several issues of this “really rare cases”. I own the GPU Issue, the noise making charging cable, the issue with switching a desktop/tablet mode (its changes random automatically) and the ghost touches.

And to this issues - sometimes the device does not shut down while i turn off the screen and fold the keyboard to screen.

God dammit…

Edit: i forgot - my pen is not usable, while charging.


#53

I suspect ghost touch is trigger by the keyboard as before my V went dead I didn’t use the keyboard on the go and got no such issue.


#54

Same with my V. It never happened that my V wakes up when keyboard is disconnected. It never happened with connected keyboard but not closed.


#55

No it is not. It is keyboard/connector problem. I am suprised by that question after all discusions… I hoped that solution is in progress…


#56

Just the day before yesterday I found my V, closed with the keyboard, inside the magnetic sleeve, which was in my messenger bag. The V was so hot that the entire outside of the messenger bag was really warm. Found ghost touches when I opened the V, and it was doing or starting a recovery. The battery was almost completely drained, so this wouldn’t have gone on for much longer, but I felt like this could have posed a fire risk if the V had been in another place. This is scary. I am absolutely positive I put the V manually into hibernate before.


#57

sorry, my bad: did not read my ‘before’ posts default_hide