[FAQ] Unable to login to web shop

webshop
faq
login

#1

Hey guys! I was trying to login to the website this morning only to discover the “Invalid login credentials” message. After trying several times, checking my password (even though I use LastPass) and whether I ended up creating an account in the first place, I opted for password reset. Before I received the reset link though, somehow I managed to log in. Thinking the problem was temporary, I disregarded the emails with the password reset links.

However, now I was trying to log in again with the same credentials message. Any clue on what is going on? I’d like to not run into these issues on Monday (o_O )

Thanks in advance for your help.

RzB

image


#2

Before anyone can fix this issue, it needs to be replicated. So anyone working on this has to need confirmation that under a certain set of circumstances the problem persists. Otherwise it’s almost impossible to trace.

Most likely though

  • a hidden character in your password (like a space?)
  • A forbidden character in your password that screw with the SQL
  • the " _ " in your email adress (but unlikely)
  • you actually have input invalid credentials.

Also, you probably have more luck reporting this on https://meta.discourse.org/ because it’s a software issue, not a theming / community issue. But before they will help you, they probably ask you to change your password, just to be sure.

I do have to admit, that not showing what login credential is invalid is a real issue from a UX point of view. There are security concerns and arguments one can make in favor of the vague feedback, personally I don’t care about those though. But i’m not adept enough in the security side.


#3

I think there are some problems with the login!

I also cant login with my credentials. Then I tried to reset my password now the page says No account found with my mail.


#4

Hiya there!

Just a quick question - are you sure you logged into the correct store? (euro.eve-tech.com for EU and eve-tech.com for the rest of the world)

Thx & have a good day,
Peter


#5

Wow, that’s kinda odd. It actually was this exact problem.

I never noticed the euro before eve-tech.com, I just rolled with the default address, oblivious to the necessity of those 5 extra characters :stuck_out_tongue: it all seems legit now. I will try logging in on other browsers too, just to make sure. Thanks @iKirin!


#6

I thought it would be as I’ve had this issue myself! :smiley:

But it’s good to hear that’s resolved now! :slight_smile:


#7

I ran into this issue until I realised that https://eve.community/ and https://eve-tech.com/ were different. I have two different logins and passwords so my username & password for eve.community doesn’t work with eve-tech.com. :sweat_smile:


#8

Oh, this is embarrassing for me now :smiley: :thinking: