[F] Disable Touch Screen and Display when keyboard is closed when computer stay on


#1

This is more of an issue when you do not want the EVE V on when you have external monitors but when I close the keyboard on the computer, it seem the keys are activating the touch screen which is casing circles on the touch screen that will not go away. This also happen anytime I close the keyboard. This should be fixed where if it detect the lid close, both screen and touch panel should also turn off or disable so there will be no contact.


#2

This is a little bit of a known problem. I don’t believe the problem lies in the keyboard touching the screen, but rather some weird software glitch.

Disabling touch while the keyboard is closed would be a good temporary solution why the real issue is being addressed though.


#3

I already did that so that it doesn’t cause the issue anymore. I hope they will get this fix, and also turning off the keyboard when it is closed would be a good thing as it is draining battery and also keeping the system warm when the computer remain on.


#4

+1 !!

I would +1 this, but i already gave all my votes :-/.
Still, have my comment at least.


#5

how did you do that?


#6

You just need to go in to Device Manager and find the touchscreen driver under Human Interface Devices. Its an annoyance to do it but it will keep the touchscreen from having phantom presses.


#7

Ah I see! Thank you. Yeah it is an annoyance, but getting those phantom touches is an annoyance as well. Just gotta decide which is worse.


#8

Just bumping this myself as I’m hitting the same issue.

I’ve disabled ‘Allow device to wake computer’ in the power management tab but it still is able to wake from sleep.

It means that I can’t put the device in my bag with confidence that it stays off and is a virtually a deal breaker.


#9

I’ve only received my V yesterday, but have already run into the same problem.
My V was lying still on the couch next to me, when suddenly the accessibility options turned on, and it started “speaking”. opening the keyboard up i saw about 6 pressure points that seemed to have been pressed a long time, and the screen was on recover account.


#10

I got the same issue.
And I have to restart the device to get rid of the “phantom touches”.
Did somebody discover a fix or workaround?

Edit: found the other huge thread about the same problem. sry for resurrecting this one…


#11

More info there guys (with some ok solutions): https://eve.community/t/ghost-touches-when-coming-out-of-sleep