Eve V v2 Booting up with EGPU/SATA Hard Drive

Not sure if this will help anyone but I just plugin my EGPU that has a SATA Hard drive to the V2 and it will not boot.

The issue I believe is happening is that it is trying to boot from the Thunderbolt 3 connected SATA Hard Drive and not the NVME drive in the V2 first which cause the V2 to just stall when trying to boot. If I boot with the Thunderbolt removed, it will work find.

The solution that i found was to disable SATA from the chipset completely in the BIOS. The setting is located in the Chipset tab. Since the V2 does not use SATA, it does not cause any issues with the booting since there is a separate NVME section for the SSD in the BIOS. I now can boot with the Thunderbolt 3 EGPU with the hard drive attach and the hard drive is still readable.

I did not find another way to change the boot device in the Bios to only boot from the SSD and not from the Thunderbolt port. Not sure if anyone else would have this issue but thought I would state it here incase others run in to this kind of issue.

3 Likes

Couldn’t you just change the boot order? It’s fairly common for a PC to place USB drives ahead in the order, and then scan them prior to booting from the internal drive. If the drive is large, and a spinner, it can slow down boot times significantly.

Just place the internal drive above the other devices in the order and it should skip your external drive.

(I’ll check this on my own V2 when I pick it up tonight)

I can’t as it freeze the system and can’t get in to the bios if the thunderbolt is plug in and you start the computer. I also didnt see a way to set priority on what can be booted in the bios.

If nobody else has an answer, I’ll try to get back to you in a couple of hours. I need to pick up my V2, and then I can test this myself.

If you can boot into Windows, you can usually boot into the UEFI interface by following the instructions here: Boot to UEFI Mode or Legacy BIOS mode | Microsoft Docs

  • … if Windows is already installed, from either the Sign on screen or the Start menu, select Power (Power button icon) > hold Shift while selecting Restart. Select Troubleshoot > Advanced options > UEFI Firmware settings.

It’s ok, i was able to find a working solution on it and disabling SATA does not affect the system anyways.