Eve V (2021) Driver Downloads

After updating my new V (2021) to Windows 11, I ran into an issue where both the touchscreen and the pen sensor were no longer operational.

Long story short, the fix was to uninstall the Wacom device and then run a scan for new devices. Windows was able to put a working driver in place after that.

My go-to solution for solving something like this would usually be to find the appropriate drivers for the device, and then install those manually. As of writing this, Eve has not yet posted these on the evedevices.com website.

Can anyone comment on what the plans are for making drivers downloadable, if necessary, or where they could be downloaded from the part manufacturers?

1 Like

X-Station also sell the V2. Their downloads are here:

Specifically, they have a complete set of V2 drivers (link in bottom-right corner)

I have heard that the machines are identical but that could be wrong, so… use at your own risk! For example, they also have a (January) BIOS download for V2 there but I think it would extremely dangerous to try to install that (it might brick your machine) and I have no idea what it’s meant to improve.

Hi guys,

This has been brought up to our attention. We will post an update here as soon as the drivers has made its way to the Eve website.

Please do not install drivers coming from other sites unless if you are sure that it is indeed for the device (which most likely it is not). For now, I can only recommend Windows driver finder as a temporary alternative.

2 Likes

Hi Brendon,
I am also having touchscreen and pen issues with my V (2021), neither work at all. At first glance it appears to be a hardware problem/defect as the system information actually says that “No pen or touch input is available for this display.”
I have sent several emails to support for over a week and do not get a response from them.
Were you able to get both the pen and the touchscreen to work? If so, would you mind please sharing the steps?
Thank you,

As @Cas has pointed out, they’re working on making the proper drivers available on the website. If you can hold out for a bit, it should be available soon. Otherwise, just do what I did and come back later when you can get the proper driver.

I cannot guarantee this will work for your case, so please do so at your own risk.

Here’s what I did to get my touch and pen working again:

  1. Open Device Manager (Right-click on Start button)
  2. Check for a Wacom device under Human Interface Devices
  3. If you look at that device’s status, it should indicate that it failed to start.
  4. I uninstalled the Wacom device (Right-click → uninstall device)
  5. I ran a scan for hardware changes (Actions → Scan for…)
  6. The device automatically reinstalled with a generic HID-compliant pen, and HID-compliant touch screen provided by Microsoft.

After that, things have been working consistently.

2 Likes

Thank you, Brendon. Much appreciated.

1 Like

Hi guys,

This is correct. At least for now, this is the temporary solution until we can get the drivers up on the website. It has been brought up to the team and we are currently working on it.

2 Likes