Can't get 4K 120HZ to work with PS5 Quake

Hi!

My setup:

  • Eve Spectrum 4K monitor
  • PS5
  • Original PS5 HDMI 2.1 cable

My problem:
I can’t get to work the 4K 120HZ mode with the PS5 version of Quake remastered.

Performance mode is enabled, resolution and 120HZ output is set to automatic. I tried every other possible setting as well, but the best I get is 4K 60HZ.

What could be the solution to my problem?

Thanks for your help!
Chris

It was an issue with the game, have you got the latest patch? More discussion here https://reddit.com/r/quake/comments/q7798x/quake_ps5_120hz_not_working/

Someone there says set the PS5 mode to automatic not performance.

FWIW I’m playing Quake and it’s at 120fps.

2 Likes