Bluetooth has disappeared


#1

I was attempting to update my system just now, and two things happened;

1- I was notified of an "Unknown USB Device (Device Descriptor Request Failed)"
2- My Bluetooth icon disappeared from the toolbars and Troubleshooter believes none is available.

I’m assuming these are related. How do I go about reinstalling the drivers?


#2

Turn the device off completely.

Wait a few seconds.

Turn it back on.

For me, when I had the same problem, it fixed it.


#4

I gave that a shot, but there’s no change. Device Manager still lists the item as “Unknown USB Device”.

Could it be related to the buggy Windows Cumulative Update? That’s what I was trying to resolve (unsuccessfully) when Bluetooth disappeared.


#5

The ratio behind turning it off and on again is that sometimes there’s a capacitor that’s keeping some obscure memory location still powered. Powering off gives a chance to this capacitor to discharge.

I said “a few seconds” but often this translate in “at least 30 seconds”.

When I had the issue, I didn’t think about this possible solution. At some point I turned off the device and then if I recall correctly turned it on again only after several hours. Give this a shot as well, just to be on the safe side.

If this doesn’t work, I’m afraid I have to pass: someone else will have to step in and give their opinion. Updating drivers by downloading the correct ones from Intel’s webite will probably be one.


#6

Is there an exclamation mark next to the ‘unknown usb device’? Anyway just delete the device and switch off the V. After switching on theV again the BT device will probably be recognized again.


#7

If that also does not work, you can try reinstalling the WiFi drivers with the ones from the support page ( Support – eve-tech.com )
I’ve seen this on other devices in the past - sometimes it seems Windows does not like WiFi cards :confused: