[B] Sleep battery power drain


Will the power even drain if I switch it off ? or is this problem only in standby mode?


I’m pretty certain the V waking up in the sleeve problem is caused by the keyboard - could be shitty magnets - but maybe it’s the pogo pins?

The rapid switching from laptop to tablet mode I think is definitely caused by the pogo pins not connecting cleanly, and maybe the ghost touch is from the keyboard discharging a current into the V?

As far as I can recall - I think all the touch circles I’ve seen in the pictures here are always toward the lower center of the screen, where the connector is.

Edit: oh lol someone did mention this: me!

You guys who are having this issue - can you try and see if the V goes to sleep (as expected) without the keyboard?

If there’s any merit at all to this guess, your V should be fine and dandy without the keyboard attached. No weird shit, no ghost touches - Nada!

…Then we can pitchfork the people who make the keyboard!

Oh, and BTW:

No, if you sleep/shut down the device, it shouldn’t drain any more than you would expect it to, these guys have a strange bug that is making their devices turn on for no reason.


I am almost certain its due to the keyboard, high probable due to the magnet, or as you speculate, current discharging out of nowhere.

Don’t think its the pogo. I have seen ghost touches in the middle of the screen, and a couple of times closer to the webcam (the top), where the space bar lies when its closed.

And without the keyboard attached, I have not experience auto wake, and I am still collecting more sample data from my daily usage.


This should go without saying, but let me remind everyone that if you put the V in the bag without the keyboard, the glass is more likely to Crack. Make sure you use some sort of protection (protection for the glass)



My display cracked, and the touch panel is disabled.

Ever since this point, I haven’t had a bit of sleep drain. Keyboard attached or not.


Somehow is the touchscreen triggering the V from going into sleep as ghost touch will be there once triggered.


Hmm, a bit heavy as a solution . . . . . .:stuck_out_tongue_winking_eye:

Sorry to hear that your display is “out”, what happened ?


Yeah, it seems that the people who have ghost touches are the same people whose Vs won’t go beddy-bye.

It’s probably the same issue imo.


Hey there,

Any news on the BIOS update? :slight_smile:


Yeah my battery drain still occurs with keyboard on. Also I now have sticky shift key issue which I’ve reported to support and THEY are waiting on Me to provide video. I wonder if the sticky shift is contributing to the barret drain by walking or up?


Well, is there any final solution? My device is unusable. Each time I close the lid, put it in bag, the device wake up and drain battery. It does not hibernate. It is really annoying… I dont’t want such device… If it is keyboard problem? Can I send it back and receive new working keyboard?


There are several workarounds, I don’t think there is a solution as yet.

I’m not an (electrical) engineer but as far as I can tell the problem is not consistent enough to come up with a fix for everyone (personally, I’ve tried to replicate the problem on my own V with NO success at all).

I mean the only way I’ve woken up my V in the sleeve is by shaking the f*cker vigorously and getting the keyboard to separate from the screen while in the sleeve to trigger the “lid open” action. Trust me the amount of effort it took, it would never happen by accident.

If it’s difficult to find the problem, it’s equally difficult to find a fix - if you’re in a boat and it’s filling with water, you need to know where the leak is to fix it (or slap the dude pissing in the boat if that’s what’s happening).

The keyboard being the source of the problem is (if my comments lead you to believe the keyboard is the source of that problem) just a guess and I can’t verify that because I only have my one V and I don’t have this issue. I just wanna blame the keyboard makers for something.

Its probably irritating as shit for you, but the simplest workaround is to remember to shutdown instead (Windows+D, alt+F4 opens the shutdown menu) until they find a fix OR they somehow find a way to prove its the keyboard.

I’m pretty sure a permanent solution to your problem is being worked on and not just being ignored.


… or to manually hibernate. It should not wake from hibernation.


I tried to close the lid, leave V for a while and then move keyboard a little. And I can see in report that device was woken up - so it’s keyboard “mistake”. BUT in this case, device went to Connected standby immediately… When it happens in bag, V stays in Active mode… why?

And I can see that Connected standby consumes a lot of battery capacity
09:26:59 Connected standby 1:59:56 2 %
11:27:03 Connected standby 1:47:28 3 %
Is it okay?


I have ONLY had this problem with the keyboard lid closed. If I left it open and just let it go to sleep, it would never just wake up. And since it does not happen to everyone, I still suspect that some keyboards are misaligned a bit and thus hit the screen and turns it on from time to time.

I changed my power options to hibernate when pressing the power button, and when I do that, I have not had a single wake up (or ghosting issue). It still only goes to sleep when I just close the lid, and then I have seen both ghosting and wakeups, even with the latest drivers from the support page.

So the best workaround I can suggest, is to let the power button hibernate the laptop. It takes about 7-10 seconds for it to wake up, but at least you’ll be sure there is power when you arrive somewhere, and you don’t need to drag the charger around with you everywhere.


How to make V hibernate as there is not selection of hibernate…


Open control panel, go to “Hardware and Sounds”, then “Power options”, then “Choose what the power buttons do”. Click “Change settings that are currently unavailable”, then “Hibernate show in power menu”, and save changes.

Alternatively, create a new shortcut to “C:\Windows\System32\shutdown.exe -h”, call it “Hibernate” (or whatever you’d like), and just use that.


Interesting behaviour over the weekend…

I switched off “modern standby” a couple of weeks ago but on Friday night my supposedly sleeping tablet was VERY hot when I took it out of its case. Also, last night, after using it for an hour or so I put it to sleep by closing the keyboard. About an hour later I heard a Windows notification sound and the V had obviously woken up but I wasn’t able to establish what had caused the notification / wakeup.


Windows updates can sometimes turn modern standby on again. I experienced this once. Might want to check the BIOS setup again :slight_smile:


But there must be something that prevents V from going to sleep mode. I think that it is OK, when something wake up V from sleep mode, do something, BUT then V should go again to sleep mode… :thinking: