[B] Sleep battery power drain


#42

I would recommend, as a first step, disabling connected standby, to see if that makes a difference:

Other thing to check is whether the network card is set to turn on the computer (as it’ll need to keep it powered to do so). See Device Manager->Network adapters->Intel Dual Band…->Power Management (and turn off “Allow this device to wake the computer”), and in the same diialog box in advanced tab, “Wake on Magic Packet” and “Wake on Pattern Match” should be set to “Disabled”.

One thing to note is that in sleep mode, the system needs to keep some components powered, so there will always be some form of battery drain. Your android tablet sounds exceptional - most tablets have battery drain when they are not fully off.

If you want to make sure that your PC has no drain, you can change the power settings so that it goes into hibernation mode after a period of time. When it’s hibernated, there will be no battery drain. And perhaps that’s what your macbook was doing.


#43

Me too. My V is as it arrived - set to sleep on close.

If I’m using the V as a tablet, put it to sleep with a power button press, attach the keyboard and then close it I get a Windows notification sound as if Windows has just woken up. Of course, if I then open it to check it wakes anyway.


#44

I encounter this for the 3rd time for no reason & is damn suck to bring along a brick which doesn’t work without the power adapter!


#45

I have noticed this as well.

I also had a problem with my V losing all charge during the night, and according to the Battery report, it was active all night long:

It seems that sometimes closing the laptop, actually takes it out of sleep mode, and it remains active for until I open it again.

I hope there is a fix for that somehow, as it is very annoying that the screen gets activated when you think it is sleeping, and there is no way to verify this, besides the notification sound. And that only comes if you sleep with the power button first.

I usually just put it to sleep by closing the keyboard up.


#46

This is progress!

this is from my battery report - so first i took the V off AC, then i flipped the keyboard up - it went into connected standby.

then i let it go to sleep due to inactivity, then flipped the keyboard up - that didn’t wake it.

again, i received my V in early Dec, and i doubt they tweaked anything in the V to make later models worse (or any different at all to be honest) so i’d surmise that something jiggling in your keyboard is waking the V, and keeping it active. can you do a /systempowerreport or /systemsleepdiagnostics (its one or the other, i can’t remember) to see what exactly woke it?

/SYSTEMPOWERREPORT Generates a diagnostic system power transition report.

/SYSTEMSLEEPDIAGNOSTICS Generates a diagnostic report of system sleep transitions.


#47

If I am reading the SystemPowerReport correctly, it seems to be this one:

So that is when I shut off the monitor after using it. Then it goes into ModernStandby for a few minutes:

Then exits due to input touch, and stays active until the next morning when Windows shuts it down due to lack of battery.

If some risk that the keyboard activates the screen from time to time, that is problematic, to say the least.

Unrelated to the battery issue (but relevant to the keyboard issue), I have twice experienced issues when opening the laptop after the keyboard had been closed. First time, there were 4 blinking circles on the screen, as if I had touched it with 4 fingers. I couldn’t do anything but shut down the laptop, and restart. Second incident, the touch pad wouldn’t react. There was a small select square on screen. I could shut it down normally by using the keyboard to restart Windows.

Could it be that some keyboards are manufactures a little crooked, and thus parts of it touches the screen in certain positions? … giving me the problems described?


#48

I think we’ve found it. You might have the “ghost molesting my screen” issue. I don’t know what causes it, i don’t exactly know what the fix is, and i don’t know if or what support is doing about it but i know its an issue that several people have reported and submitted tickets for. You might want to do the same.

This and the sleep-drain-battery thing are likely related, but this is the first (that i’ve seen) strong evidence that supports that the two are related. i’ve suggested it before but nobody ever came back with evidence that my guess was anything more than a guess.

people seem to think when i ask for powercfg reports i'm trying to spy on their porn habits. i wonder why.

From LOL i see you were watching porn on the 28th for 3 hrs:

I think a temporary workaround would be to disallow touch from waking the device or diabling touch input completely

Can anybody else with the V-sucks-battery-while-asleep issue also comment on whether they too have ghostmolestingmyscreenitis?


#49

I’ll make a Support case now, and give them the input above as well :slight_smile:


#50

How do I switch off touch from waking the device?


#51

Uh… Device manager or advanced power settings, maybe?

I don’t really remember but I know it’s on the forum somewhere. Try searching the forum for “disable touch”.

Edit: I found this in a pm, so it might not be on the forum lol.

Device manager and instead of mouse probably HID touch input or something.


#52

It seems that HID compliant Mouse is the only device that allows to wake the laptop, and if you disconnect the keyboard, that device will not register as connected anymore.

I have tried switching it off. Not sure if that will have an effect.

I can still active the display with the touch pad.


#53

Wait - touch input means the screen, not trackpad, and the device I’m thinking of has touch in the name.

It isn’t mouse - that’s input mouse (and that guy was talking about something else) - I just shared that to show device manager is where the “allow to wake” settings are.

I can’t really remember offhand though. If there isn’t any device with “touch” in the name then I’m stumped. “Touchscreen”? “Touch panel” ?


#54

All I found was HID Keyboard Device (besides the mouse), that allows for wake. All the other Human Interface Devices do not allow for this option (and all were switched off anyways).


#55

Well then I have no idea. Anyway I scrolled up and saw that disabling everything from waking also didn’t up some people.

At this point I’m not sure if your problem is this problem or the ghost touch problem or if they’re the same damn problem. It might even be a problem with connected/modern standby apparently. Wait on support I guess.

Here - as consolation, have a video of a bunch of chicks singing about touching stuff.

Edit: I watched it and mebbe it’s a bit NSFW.


#56

I realise my battery was drained from 7x% to 12 % as well, but I switched it off so it wasn’t even in sleep mode or anything.


#57

Open cmd or powershell and do powercfg /batteryreport to verify that. If your V drained 60% while switched off then you’ve got a whole different problem altogether.


#58

I’ll check that but it only happened once as far as I could tell, though gadgets and anything electronic always act funny in my presence :sweat_smile:
Will definitely report if occurred again, thanks anyway


#59

Well, nothing I did worked :slight_smile: … it still wakes up sometimes when I close the keyboard (i hear the notification, and Battery Report confirms this).

But I have dialog with Support, so I hope they can give me more info on what is going on.


#60

Let us know if you figure it out. Right now the only strong evidence I have indicates that my guess is still just a wild guess. :no_mouth:

Back to making stuff up!


#61

I had the ghosting issue and support sent me to the display driver update. Can’t remember if the latest update is on the site but if you’re talking to support ask them to look at ticket 7801.