[B] Sleep battery power drain


#1

What does happen?

In sleep mode (InstantGo/Connected Standby), the battery drains at around 2% per hour. 2% per hour translates to around 1W of power consumption during standby.

What should happen?

Per Microsoft’s documentation here https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/36463e42-7d6e-408e-933f-dbf56ea41e65

Systems that support Connected Standby MUST drain less than 5% of system battery capacity over an 16 hour idle period in the default shipping configuration.

Therefore, the battery drain must be around 0.3% per hour at worst, or roughly equals to 0.15W power consumption in standby.

How often does this occur?

Every sleep, with InstantGo enabled (default setting)

How can we reproduce this issue?

Put it into sleep mode for more than 10 minutes, then run either battery report command powercfg /batteryreport /output %USERPROFILE%\Desktop\battery_report.html or the sleep study command here powercfg /sleepstudy /output %USERPROFILE%\Desktop\sleepstudy_report.html to analyze the issue

From what I see, in energy report here powercfg -energy -output %USERPROFILE%\Desktop\Power_Efficiency_Diagnostics_Report.html you can see that ASPM is disabled in the system. It might be the cause.


#2

What sleep states/mode is the V currently using?

Also can you turn off the WIFI before putting it into sleep mode for more than 10 minutes. Is the power drain the same as before?

The culprit might be that the V is still connecting to the internet even in sleep mode doing something dodgy.

To activate the ASPM, go to Power Options>Advanced Settings>PCI Express>Link State Power Management and change settings to Maximum Power Savings.

Maximum Power Savings

If you select the Maximum Power Savings, the power savings are greater, but the time to recover from the Sleep state (latency) is much longer, so it will use less power but will take longer when you try to restart your work.

In any case, this will get rid of the error your getting in powercfg energy report.


#3

I tried that setting but it didn’t make a difference. It still came up with the same error message that ASPM is disabled because of a hardware incompatibility.


[Summary] Software Improvements Progress (keep updating)
#4

I had my laptop in sleep mode for 9 hours last night. I disconnected the mains just when I put it to sleep. When I woke it up this morning, it was at 97%, so it lost 1% every 3 hours. That doesn’t seem too bad to me.


#5

This is interesting, it’s less drain than my SP3. Can you generate a battery report and sleep study report? Particularly sleep study cs it contains the details on what the system was doing while in sleep mode


#6

Actually, it’s probably explained by the fact that I have connected standby turned off.


#7

Hi I tried to enter the PCI Express settings but unfortunately my energy plan do not have settings for PCI or Wlan.
Do I miss drivers here? Any idea?


#8

PCI Express setting is hidden by default on devices with Connected Standby enabled. If you want to reveal that setting, you can either disable CS, or use a registry hack below (which would allow you to keep CS enabled)

I have tried it though, and I still get the warning about ASPM being disabled.


#9

Actually, I don’t think it’s that. I think it’s because you are using the balanced power plan, which has the slider in the task bar. Change it to one of the other plans and you will have all the options.


#10

Question, does leaving it in max performance mode affect battery drain in sleep mode? I’ve been suffering from excessive sleep drain too even after disabling LPS0


#11

Thanks @Patrick_Hermawan for the guidance, here’s the sleep report that gives the intel on why my battery drained, all I can see last night is that the monitor came on… not sure why… it was on a desk and everyone was asleep, but looks like it went into standby for a minute, then became active and stayed active for nearly 6 hours!

Any advice guys?

(p.s. awesome you can get these reports!)


#12

hi Phil, I only have a balenced plan, thats it. I dont know how to get the normal other plans. For sure I could create my own one, but there are also no other settings and no pci express …


#13

As a update. I’ve put the V into the “better performance” mode and put the V into sleep manually (windows>power>sleep) last night at 76% and woke up this morning… with 76%!

Will try again tonight with “best performance” again to see if any difference.


#14

Windows Settings->System->Power and Sleep->Additional Power Settings - > Show Additional Plans -> Select “Power Saver” or “High Performance”. Once you’ve selected one of these plans, click on “Change Plan Settings”. All the options will be there.


#15

due to Fall Creators Update of windows 10 all power settings despite balanced were deleted (found it by google).
Maybe in the same way the settings for Wlan, PCI Express etc are not visible any more…see my hardcopy before.

@iKirin any chance to download/ get the standard win 10 V power settings plans for Power Saver and High performance back?


#16

When I click on my battery icon in the task bar, there are options there… Or am I looking at something else?


#17

Hiya!

Yeah, you’re right they’re gone!

I’ll check it out over the weekend on my old notebook and see if the power settings are gone there as well - might very well be that MS removed them in favour of the nice fancy slider @Kee photographed!


#18

You’re looking at the wrong settings screen - that’s the “Edit Plan Settings” screen, which you can get to by selecting “Choose when to turn off the display”. If you follow my above instructions (Windows Settings->System->Power and Sleep->Additional Power Settings), it will take you to the correct screen that looks like this:


The you just need to click on “show additional plans”.

I’m also using the Fall Creators Update, so that doesn’t stop you from accessing the screen with the additional power plans.


#19

as said Phil, I dont have other Plans, see below.

Maybe ikirin find something over the weekend as mentioned (I hope so).
The slider is not transparent for me, I dont know whats going on in the background. Eg. is wifi going down despite I wanted to have it full etc…


#20

I just checked mine and same thing. I only have the one and only plan. Nothing else.