[B] palm rejection and pen issues while charging


#1

What does happen?
When charging the eve, palm rejection stops working like it should. It sometimes stops recognizing the palm for short times which results in lots of unwanted movements/zoom in and outs. When palm rejection is working the pen “drops ink” when hover him above the screen. I can upload a picture later on.
If you don’t touch the screen with your hand/palm while using the pen, it works like it should.

What should happen?
palm rejection and pen should work as if the eve is not charging

How often does this occur?
Every time the Eve is charging

How can we reproduce this issue?
Plug it in for charging and try writing something


Artists of Eve V
#2

I don’t think I’ve realized it specifically while charging.
I agree in that I think it occurrs more often but not as severe. I’ve been off charge and it’ll just not properly pick up my pen strokes.


#3

While off charging palm rejection works mostly fine for me, but while charging it is nearly impossible to write while my palm is resting on the screen and i have little dots all over the place from the pen dripping.


#4

Little dots like the touch response dots you’d get if you used your finger or tiny ones like the one the pen creates?


#5

tiny dots that the pen would normally create if you touch the screen (i am writing in onenote where only pen input draws)


#6

Strange. I’ve never run into this.

On another note, what I have noticed is that when the pen is missing strokes you can see that the distance the pen can be recognized by the screen (creating that small dot) decreases, sometimes to the point that even having the pen touching the screen won’t make the pen dot appear. And moving the pen will make the dot lab and disappear and reappear off and on.


#7

Hi Eve Team ialsohave the issue with having problems in writting while charging of my Eve V How can we repir this problem?


#8

Vote for this thread to make it hot and that will get the team’s attention :slight_smile: see the red Vote button at the top of the original post


#9

Just tried this out on my m3 and yes I can confirm I have the same issue. Voted hot!

Note: this doesn’t seem to affect all Vs… just had a convo with another V owner and theirs was fine…


#10

Ok, sorry for multiple posts, but I’ve fixed it now! :slight_smile:

Basically I reinstalled the Touch Drivers from the Support page, restarted the V and now all is good!!

Weird because I installed all the latest drivers when I got my V, but somehow it undid itself…

EDIT: pls try this and see if it works for you. I’ve removed my Solution tag since it seems that others have tried a similar fix and the issue came back… here’s hoping that’s not the case here!


#11

I installed the driver again, restarted and it seems to be fixed right now :grinning:
I already installed this driver before but maybe i forgot to restart, or i messed it up with the n-trig calibration tool i tried. I still would let this topic open, since even more votes came in. I’ll try some more and report back if it comes back or not.

Edit: Problem still exists… :expressionless:


#12

Have you raised a ticket with support as well?


#13

No i haven’t done this yet. I thought it maight be a generell problem.
I just tried the same scenario under linux and the problem exists there as well.
I could imagine this problem has something to do with the hole “not grounded charging cable” thing. While charging the case of the eve, it might be staticly charged or atleast there are other electric fields. This could conflict the digitizer which detects the inputs based on capacitys.
I will try to ground the casing of the eve and see if the problem still exists.


#14

So the thing that seems to solve it for me actually seems to be restarting the V. The issue of missed strokes whilst charging (and sometimes also when not charging) was solved yesterday, but then today it reappeared, so I tried the age old IT trick of restarting the machine and hey presto… all fixed.

Seems like a software thing to my untrained guestimation… really hoping eve engineers can have a look at pls pls pls…


#15

This is my own test reproducing the same issue. So is present in the new devices too.


#16

Would like to bump this topic as I am experiencing the same issue of palm rejection failing to work when eve is charging. Any one in development team looking into this?


#17

Yes, iKirin has indicated that they are looking into this. However, nothing was done over CNY which is why there have been no updates recently.


#18

Just encountered this issue. Been using for months without realizing it because I seldom write with the V charging.

And when I did… crap… the palm detection was like non existence. Luckily I remembered I saw this thread before so at least I know where the problem lies – CAN’T WRITE WHEN V IS CHARGING.


#19

Same here, just realised that this issue affected me too.

Restarting and installing the new driver didn’t work.

However I found a new way to trigger the bug. Basically plug anything into the either both the USB-C port, USB-A ports, and the headphone jack. The bug will be reproduceable. I haven’t tested this using the included alcantara keyboard, because I’m waiting for a replacement.


[B] Palm rejection / hover distance
#20

Saaaaaaame. The V isn’t usable while charging. Dissapointing…