[B] Keyboard does not register all key presses when connected to bluetooth

keyboard

#41

Well in theory not really. Bluetooth has different profiles/categories which it uses when a peripheral is connected. That depends on a peripheral that is connected what BT profile it wants to use/needs to use.

Different profiles have different options in drivers. What I mean here is that the driver pretty much tells the hardware how to operate. So maybe it more of a driver problem/firmware problem than a hardware problem.


#42

Is EVE officially looking into this / testing it?


#43

I’ve just being having this issue and it generally happens either when I do the following:

  • Let go of a modifier key (Ctrl, Shift etc) and try to press a letter key quickly after. So words like ‘You’ becomes ‘Yo’. (Press Shift, Press Y, Depress Shift, Press O, Press U).
  • Sometimes a double press of a letter key doesn’t register the second keypress. So worlds like ‘really’ can become ‘rely’.

I’ve also noticed that there is some latency between typing the letter and it appearing on the screen. The longer the latency, the more likely that the missing keypresses appear :confused:

Edit: Just tried with the Intel 20.X update for bluetooth and still have the same issue.


#44

i guess this really belongs here instead of the thread its in.


#45

There is still no solution to this problem?


#46

I guess no. That is bad news, since it practically negates the benefits of detachable keyboard.